A + B Problem II
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
典型的大整数加法题目,要注意输出格式。
代码:
#include <cstdio>
#include <cstring>
struct bign{
int d[1010];
int len;
bign(){
memset(d,0,sizeof(d));
len=0;
}
};
bign change(char s[]){
bign a;
a.len=strlen(s);
for(int i=0;i<a.len;i++) a.d[i]=s[a.len-1-i]-'0';
return a;
}
bign add(bign a,bign b){
bign c;
int carry=0;
for(int i=0;i<a.len||i<b.len;i++){
int temp=a.d[i]+b.d[i]+carry;
c.d[c.len++]=temp%10;
carry=temp/10;
}
if(carry) c.d[c.len++]=carry;
return c;
}
void print(bign a){
for(int i=a.len-1;i>=0;i--) printf("%d",a.d[i]);
}
int main(){
int T;
scanf("%d",&T);
int kase=0,first=1;
while(T--){
char s1[1010],s2[1010];
scanf("%s %s",s1,s2);
bign a=change(s1);
bign b=change(s2);
bign c=add(a,b);
if(first) first=0;
else printf("\n");
printf("Case %d:\n",++kase);
print(a);
printf(" + ");
print(b);
printf(" = ");
print(c);
printf("\n");
}
return 0;
}