HDU 463 No Pain No Game (树状数组+离线处理)

Problem Description

Life is a game,and you lose it,so you suicide.
But you can not kill yourself before you solve this problem:
Given you a sequence of number a1, a2, ..., an.They are also a permutation of 1...n.
You need to answer some queries,each with the following format:
If we chose two number a,b (shouldn't be the same) from interval [l, r],what is the maximum gcd(a, b)? If there's no way to choose two distinct number(l=r) then the answer is zero.

 

 

Input

First line contains a number T(T <= 5),denote the number of test cases.
Then follow T test cases.
For each test cases,the first line contains a number n(1 <= n <= 50000).
The second line contains n number a1, a2, ..., an.
The third line contains a number Q(1 <= Q <= 50000) denoting the number of queries.
Then Q lines follows,each lines contains two integer l, r(1 <= l <= r <= n),denote a query.

 

 

Output

For each test cases,for each query print the answer in one line.

 

 

Sample Input

1 10 8 2 4 9 5 7 10 6 1 3 5 2 10 2 4 6 9 1 4 7 10

 

 

Sample Output

5 2 2 4 3

 

参考大佬的博客http://www.cnblogs.com/kuangbin/archive/2013/07/30/3225627.html

#include <stdio.h>
#include <algorithm>
#include <string.h>
#define LL long long
using namespace std;
const int MAX = 5e4 + 50;
LL INF = 1e18;

int a[MAX];
int ans[MAX];
int c[MAX];
int last[MAX];
int n;

int lowbit(int x){
    return x & (-x);
}

void Update(int i, int k){
    //printf("i = %d n = %d\n", i, n);
    while(i <= n){
        //printf("999\n");
        c[i] = max(c[i], k);
        i += lowbit(i);
    }
}

int getmax(int i){ 
    int res = 0;
    while(i > 0){
        res = max(c[i], res);
        i -= lowbit(i);
    }
    return res;
}


struct date{
    int l, r;
    int st;
} node[MAX];


bool cmp(date A, date B){
    return A.l > B.l;
}

int main(int argc, char const *argv[])
{
    int t;
    scanf("%d", &t);
    while(t--){
        memset(c, 0, sizeof(c));
        memset(last, 0, sizeof(last));
        scanf("%d", &n);

        for(int i = 1; i <= n; i++){
            scanf("%d", &a[i]);
        }

        int m;
        scanf("%d", &m);
        for(int i = 0; i < m; i++){
            int l, r;
            scanf("%d%d", &l, &r);
            node[i].l = l;
            node[i].r = r;
            node[i].st = i;
        }
        
        sort(node, node + m, cmp);

        int j = 0;
        int i = n;

        while(j < m){
            while(i >= node[j].l && i > 0){
                for(int k = 1; k * k <= a[i]; k++){
                    if(a[i] % k == 0){
                        if(last[k]){
                            Update(last[k], k);
                        }
                        last[k] = i;

                        if(k * k != a[i]){
                            int p = a[i] / k;
                            if(last[p]){
                                Update(last[p], p);
                            }
                            last[p] = i;
                        }
                    }
                }
                i--;
            }

            while(j < m && node[j].l > i){
                ans[node[j].st] = getmax(node[j].r);
                j++;
            }
        }
        for(int i = 0; i < m; i++){
            printf("%d\n", ans[i]);
        }
    }
    

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值