Mayor's posters (线段树+离散化)

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

 

由于数据范围很大,数量很少,所以我们可以离散化。

然后我们选择从后往前贴,每次贴的时候判断要贴的区域是否贴满,贴满了就不用贴。

所以我们的线段树只需要维护该区间是否被贴满就好了

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <queue>
#include <math.h>

#define LL long long
using namespace std;
const int MAX = 25000;
int INF = 1e8;
int lsh[MAX << 1], cnt, n; //n 原数组大小 num 原数组中的元素 lsh 离散化的数组 cnt 离散化后的数组大小 

int tree[MAX << 2];

struct node
{
	int l, r;
}op[MAX]; //记录每次操作
void PushUp(int rt){
	if(tree[rt << 1] && tree[rt << 1 | 1]){ // 如果左右子树都贴满了,则该区域也贴满
		tree[rt] = 1; // 1代表贴满,0为未贴满
	}
}

void PushDown(int rt){
	tree[rt << 1] = tree[rt << 1 | 1] = 1;
}

void Build(int l, int r, int rt){ // 初始化线段树
	tree[rt] = 0;
	if(l == r){
		return ;
	}
	int m = (l + r) >> 1;
	Build(l, m, rt << 1);
	Build(m + 1, r, rt << 1 | 1);
}

int L, R; //每次操作的区间
int fg = 0; //判断是否又贴这张海报
void UpdateRange(int l, int r, int rt){
	if(L <= l && r <= R){
		if(tree[rt] == 0){ //未贴满,则表示当前海报可贴
			fg = 1;
			tree[rt] = 1;
		}
		return ;
	}

	if(tree[rt]){ // 向下更新
		PushDown(rt);
	}

	int m = (l + r) >> 1;
	if(L <= m){
		UpdateRange(l, m, rt << 1);
	}
	if(R > m){
		UpdateRange(m + 1, r, rt << 1 | 1);
	}
	PushUp(rt);
}


int main(int argc, char const *argv[])
{
	int t;
	scanf("%d", &t);

	while(t--){
		int n;
		scanf("%d", &n);
		int cnt = 0;
		for(int i = 1; i <= n; i++) {
			int l, r;
			scanf("%d%d", &l, &r);
			op[i].l = l;
			op[i].r = r;
			lsh[++cnt] = l;
			lsh[++cnt] = r;
		}
		Build(1, cnt, 1);
		sort(lsh + 1, lsh + cnt + 1); // 离散化操作
		cnt = unique(lsh + 1, lsh + cnt + 1) - lsh - 1;
		int ans = 0;
		for(int i = n; i > 0; i--){
			fg = 0;
			L = lower_bound(lsh + 1, lsh + cnt + 1, op[i].l) - lsh;
			R = lower_bound(lsh + 1, lsh + cnt + 1, op[i].r) - lsh;
			UpdateRange(1, cnt, 1);
			ans += fg; // 贴了fg为1,没贴为0
		}

		printf("%d\n", ans);
	}

	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值