Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.
The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.
In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Viof all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.
Input
The input file includes several test cases.
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤m ≤ 1000000) indicating the number of cities and roads.
The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ | Vi| ≤ 20000)
The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.
Output
The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)
Sample Input
6 5 1 2 2 3 3 4 1 2 1 3 2 4 3 4 5 6
Sample Output
7
emmm。。。一眼题。。bfs!!!!然后疯狂T。。。
看了一下题解,拓扑序。。。。得出结论,DAG用拓扑序会快很多
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <map>
typedef long long LL;
using namespace std;
const int MAX = 2e5 + 50;
LL INF = 1e18;
int n, m;
struct Edge
{
int to, next;
} edge[MAX * 10];
int k, head[MAX];
void add(int a, int b){
edge[k].to = b;
edge[k].next = head[a];
head[a] = k++;
}
LL w[MAX];
int in[MAX];
int out[MAX];
LL dp[MAX];
void top_order(){
queue<int> que;
for(int i = 1; i <= n; i++){
dp[i] = -INF;
if(!in[i]){
que.push(i);
dp[i] = w[i];
}
}
while(que.size()){
int u = que.front();
que.pop();
for(int i = head[u]; i != -1; i = edge[i].next){
int to = edge[i].to;
in[to]--;
if(dp[to] < dp[u] + w[to]){
dp[to] = dp[u] + w[to];
}
if(!in[to]){
que.push(to);
}
}
}
}
int main() {
while(~scanf("%d%d", &n, &m)){
k = 0;
for(int i = 1; i <= n; i++){
in[i] = out[i] = 0;
head[i] = -1;
scanf("%lld", &w[i]);
}
for(int i = 0; i < m; i++){
int a, b;
scanf("%d%d", &a, &b);
add(a, b);
in[b]++;
out[a]++;
}
top_order();
LL ans = -INF;
for(int i = 1; i <= n; i++){
if(!out[i]){
ans = max(ans, dp[i]);
}
}
printf("%lld\n", ans);
}
return 0;
}