Test for Job(topo+动态规划)

话不多说先上题目


                                           Test for Job
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 10393 Accepted: 2429

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profitVi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases.
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads.
The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ | Vi| ≤ 20000)
The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint



有向无环图 最短路径  或最大路径  可以采用 topo排序+动态规划来做

不说了,实在太easy了

话说这题很水  但也有一些要注意的地方

就是    dp[i]可以为负值,所以一开始dp 和 ans 都得设置成无穷小     而且,最后答案要输出出度为0的点的dp值

那么。。为什么这么水的题目。。十分钟敲完了代码。。却wa了无数次,,卡了我好几个小时呢

看了网上的代码。。卧槽跟我的思路一样啊,唯一的区别就是他们没有用STL。。。然后我把STL里的vector和queue改掉了,立马ac

着实吓了我一跳,,还有题目用STL是不能过的??我想那也不至于wa把  最多最多超时(不过我还没遇到过)

回过头来仔细想想。。如果用数组邻接表+head[]形式的那种流行写法。。。。。因为有多组case。。。所以我的问题很明显了

那就是没有及时清空vector里的内容  这里的vector功能其实跟head一样  是记录与一个点相邻的各个点   很明显每一次case前都应该将它清空

只需要在后面的代码的那个循环里加一句clear就ok啦。。。

真是不仔细。。而且做题经验太少了啊啊啊啊。。。。。哭

#include <cstdio>
#include <vector>
#include <queue>
#include <string.h>
#include <algorithm>
using namespace std;
#define INF 2100000000
#define M 1200005
#define N 100005
int w[N], in[N], out[N], dp[N];
vector<int> G[N];
int n, m, ans;

void topodp()
{
    queue<int> q;
    for(int i = 1; i <= n; i++){
        if(in[i] == 0){
            dp[i] = w[i];
            q.push(i);
        }
    }
    while(!q.empty()){
        int t = q.front();
        q.pop();
        for(int i = 0; i < G[t].size(); i++){
            int k = G[t][i];
            dp[k] = max(dp[k], w[k] + dp[t]);
            in[k]--;
            if(!in[k])    q.push(k);
        }
    }
}

int main()
{
    while(scanf("%d %d", &n, &m) != EOF){

        memset(in, 0, sizeof(in));
        memset(out, 0, sizeof(out));
        for(int i = 1; i <= n; i++){
            scanf("%d", &w[i]);
            G[i].clear();//这句话非常重要
        }
        for(int i = 1; i <= m; i++){
            int from, to;
            scanf("%d %d", &from, &to);
            in[to]++;
            out[from]++;
            G[from].push_back(to);
        }

        int ans = -INF;
        for(int i = 1; i <= n; i++)
            dp[i] = -INF;
        topodp();
        for(int i = 1; i <= n; i++)
            if(out[i] == 0)     ans = max(ans, dp[i]);
        printf("%d\n", ans);
    }
    return 0;
}



Python topoJSON 库主要用于处理和生成 TopoJSON 文件,TopoJSON 是一种地理空间数据压缩格式,它结合了矢量地图、拓扑信息以及高级压缩技术。这种格式由 Michael Bostock 开发,并且能够非常有效地表示复杂的空间数据集。 在 Python 中,你可以通过安装名为 `topojson` 的库来利用 TopoJSON 功能。这个库允许用户创建、读取、转换和操作 TopoJSON 格式的文件。 ### 安装 topopython 为了在你的 Python 环境中使用 `topopython` 库,你需要先将其安装到你的系统上: ```bash pip install topopython ``` ### 使用示例 假设你有以下 JSON 数据: ```json { "type": "Topology", "objects": { "world": [ {"type": "Polygon", "id": 0}, {"type": "Polygon", "id": 1} ] }, "geometries": [], "links": [], "meta": {} } ``` 你想将这样的 JSON 转换为 TopoJSON 文件,首先需要导入相应的模块并编写一些代码: ```python from topopython import TopologyEncoder # 将 JSON 字符串转换为 Python 对象 data = """ { "type": "Topology", "objects": { "world": [ {"type": "Polygon", "id": 0}, {"type": "Polygon", "id": 1} ] }, "geometries": [], "links": [], "meta": {} } """ # 解析 JSON 数据 import json topo_data = json.loads(data) # 创建编码器实例并将 JSON 数据传递给它 encoder = TopologyEncoder() topojson_output = encoder.encode(topo_data) print("Generated TopoJSON:") print(topojson_output) ``` 这只是一个基本示例。实际上,`topopython` 提供了许多其他功能,如解析、合并和分割 TopoJSON 文件等。 ### 相关问题: 1. **如何优化大型地理数据集的存储与传输**? - 使用 TopoJSON 可以显著减少地理数据的体积,同时保留所有拓扑关系,这对于大数据集来说是一个巨大优势。 2. **Python topoJSON 库支持哪些数据格式**? - Python topoJSON 库通常支持多种输入格式(例如 GeoJSON 或简单的 JSON),可以将它们转换为 TopoJSON 输出。 3. **在什么场景下使用 TopoJSON 最有效**? - 当处理大量复杂的地理数据,尤其是在需要高效处理和传输数据的Web应用或者GIS项目中,使用 TopoJSON 可以极大地提高性能并节省资源。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值