Vieux-部分型号iPhone\iPad\iPod降级工具使用教程

Vieux-部分型号iPhone\iPad\iPod降级工具使用教程

此Blog简述了如何使用开源项目Vieux给部分型号iPhone\iPad\iPod降级。
内容源于Vieux的README与实际测试,如有意外情况发生,请参考项目issue

刷机/越狱有风险, 数据无价请谨慎操作!!!


您需要准备的


  • 一台装有macOS的电脑(黑苹果与白苹果皆可),版本须在10.14.x或更高。
    • 注意:由于虚拟机不兼容CHECKM8越狱工具,所以虚拟机内的macOS不可用于执行降级
  • 合适的iOS设备 - 如果你的设备是32位CPU,你需要先行越狱并开放OpenSSH通道。
    • 注1:关于CPU的位数,可以百度您的机型获取到。
    • 注2:博主未测试过此工具在32位设备上的工作情况。
  • 看懂本教程的能力。 (Vieux-README.md原话)一定的英文阅读能力或翻译软件使用能力。


支持的设备


iOS 10.3.3

iPhone 5s, iPad Air, iPad Mini 2 (其中iPad4,6不支持)


iOS 8.4.1

iPhone 5, iPhone 4s, iPad 2, iPad 3, iPad 4, iPad Mini 1, iPod 5


iOS 6.1.3

iPhone 4s, iPad 2 (其中iPad2,4不支持)



Viuex工具的使用命令 (可忽略)

Usage: viuex [OPTIONS] [IPSW PATH (If required)]

Options:

  -i, --ipsw PATH		Path to IPSW file
  -c, --clean			  Clean up any leftover files
  -k, --kdfu PATH		"Path/To/patchiBSS" Enter KDFU mode (32 Bit Only, device must be jailbroken)
  -l, --list			  List what devices can be restored to what iOS versions
  -p, --pwn		      Enter PWNDFU mode, which will also apply sig patches (64 Bit Only)
  -r, --restore		  "Path/To/.ipsw" Just restore to a custom ipsw
  -s, --shsh PATH	  "Path/To/Save/Location/" Save OTA blobs to a given path for future use (64 Bit Only)
  -v, --version			List the version of the tool
  -y, --credits			List credits and Big Yoshi

注:如果需要用到其他的command,建议移步Vieux项目获取原始资料,本教程不多赘述。



准备环境

  1. 您需要明白接下来的操作在终端下执行(terminal),中途关闭终端可能导致您需要重新使用cd命令切换路径。
    在这里插入图片描述
  2. 您需要确认macOS上装有Python3(版本大于等于3.5), 否则需要手动安装。
    在这里插入图片描述
  3. 您需要确认macOS上装有Python2 (macOS自带Python2)。
  4. 您需要将Vieux保存至本地,这里给出两种方法:
    下载完整zip包后解压至桌面(便于查找路径)。

    在macOS下有Xcode,或者网速给力时推荐: 使用命令
    cd ~/Desktop
    git clone https://github.com/MatthewPierson/Vieux.git
    下载成功结果 数字可能稍有变动
  5. 安装Vieux所需的依赖包。
    cd 1033-OTA-Downgrader
    pip3 install -r requirements.txt


正式开始

  1. 将你需要刷入的固件包(*.ipsw)拷贝至桌面的1033-OTA-Downgrader文件夹内。
  2. 使用数据线连接手机与电脑。
  3. 32位设备请确认打开了OpenSSH,设备处于正常模式。 64位设备请确认手机处于DFU模式。
  4. 执行命令:./vieux -i PATH/TO/.ipsw
    注意:请替换 PATH/TO/.ipsw 为您的固件包完整文件名,如iPhone_4.0_64bit_10.3.3_14G60_Restore.ipsw
  5. 已知对于5s,这一步是等待刷机结束。而Vieux作者称此步为跟随终端中提示的步骤执行动作。请视实际情况操作
  6. 完成


已知问题

  • 如果遇到usb.core.NoBackendError
    执行以下命令:
    brew install libusb
    
    如果brew提示:
    Error:The following directories are not writable by your user:
    /usr/local/share/man/man8
    You should change the ownership of these directories to your user.
    	sudo chown -R $(whoami) /usr/local/share/man/man8
    And make sure that your user has write permission.
    	chmod u+w /usr/local/share/man/man8
    
    请执行:
    sudo chown -R $(whoami) /usr/local/share/man/man8
    chmod u+w /usr/local/share/man/man8
    
    然后再次尝试:
    brew install libusb
    

如果发生其他情况,请移步项目issue看看是否是已知的问题与是否有解决方案。



致谢

Vieux的contributors们

@axi0mX - Checkm8/ipwndfu
@tihmstar - Futurerestore/tsschecker
@linushenze - SecureROM Signature Check Remover
@geohotz - Fork of ipwndfu ported to Python3
@Vyce_Merculous - General help/Cleaning up my messy code
@xerusdesign - Testing
Schnob - Testing/Fixing non-cellular iPad support

博主的同好(们)

子豪Alexend - 确认了工具在5s降10.3.3的情况下好使。



©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页