PATA 1009 Product of Polynomials (25分)
题目描述:This time, you are supposed to find A×B where A and B are two polynomials.
输入格式:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 … NK aNK where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK <⋯<N2 <N1 ≤1000…
输出格式:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
输入样例:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
输出样例:
3 3 3.6 2 6.0 1 1.6
题意:多项式对应的项相乘
思路:记录每个项再对应相加,简单题。
注意输入的&和输出对应的数据类型%lf!
优化:可以只用1个数组,可参考柳神的代码
注意判断double类型用0.0 虽然与0的效果一样,但0.0更准确
代码:
#include <iostream>
using namespace std;
int main(){
int a,b;
double pola[1001]={0},polb[1001]={0},pol[2001]={0};
scanf("%d",&a);
for(int i=0;i<a;i++){
int num;
double k;
scanf("%d %lf",&num,&k);
pola[num] = k;
}
scanf("%d",&b);
for(int i=0;i<b;i++){
int num;
double k;
scanf("%d %lf",&num,&k);
polb[num] = k;
}
for(int i=1000;i>=0;i--){
for(int j=1000;j>=0;j--){
pol[i+j] += pola[i]*polb[j];
}
}
int n=0;//记录不为0
for(int i=0;i<2001;i++){
if(pol[i]!=0){
n++;
}
}
printf("%d",n);
for(int i=2000;i>=0;i--){
if(pol[i]!=0.0){
printf(" %d %.1lf",i,pol[i]);
}
}
return 0;
}
}
GOGOGOGO!
Love Joyee forever!今天红薯,麻辣烫,烤鸡翅!