PATA 1065 A+B and C (64bit) (20分)

PATA 1065 A+B and C (64bit) (20分)

题目描述:Given three integers A, B and C in [−2^​63, 2^​63], you are supposed to tell whether A+B>C.


输入格式:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).
​​ .

输出格式:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

输入样例:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

输出样例:

Case #1: false
Case #2: true
Case #3: false

题意:判断a+b是否大于c,需要注意的是a,b,c的范围为 [−2^​63, 2^​63],即便在使用long long的情况下仍会可能出现溢出。
思路:所以判断要分为以下4种情况讨论,if(a>0&&b>0&&sum<0) flag = true;
else if(a<0&&b<0&&sum>=0) flag = false;
else if(sum>c) flag = true;
else flag = false;
总之,注意类型的范围就可,本题不难。
附数据类型的范围:
整型:

byte:-2^7 ~ 2^7-1,即-128 ~ 127。1字节。Byte。末尾加B

short:-2^15 ~ 2^15-1,即-32768 ~ 32767。2字节。Short。末尾加S

有符号int:-2^31 ~ 2^31-1,即-2147483648 ~ 2147483647。4字节。Integer。

无符号int:0~2^32-1。

long:-2^63 ~ 2^63-1,即-9223372036854774808 ~ 9223372036854774807。8字节。Long。末尾加L。(也可以不加L)

浮点型:

float:4字节。Float。末尾加F。(也可以不加F)

double:8字节。Double。

字符型:

char:2字节。Character。

布尔型:

boolean:Boolean。

代码:

#include <cstdio>
using namespace std;
int main(){
	int t;
	scanf("%d",&t);
	long long a,b,c;	
	for(int i=1;i<=t;i++){
		scanf("%lld %lld %lld",&a,&b,&c);
		long long sum=a+b;
		bool flag;
		if(a>0&&b>0&&sum<0) flag = true;
		else if(a<0&&b<0&&sum>=0) flag = false;
		else if(sum>c) flag = true;
		else flag = false;
		if(flag == true){
			printf("Case #%d: true\n",i);
		}else {
			printf("Case #%d: false\n",i);
		}
		}
	return 0;
} 

参考文献:csdn、8种基本数据类型及取值范围、https://blog.csdn.net/qq_25800311/article/details/82945852
GOGOGOGO!
Love Joyee forever!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值