2022-5-16 树的叶子节点个数

树的深度

题目

给出一棵n个节点的树,节点编号为1-n(根节点编号为1),求这棵树叶子结点的数量。

例如:

1─2─4─5
└─3

其中3和5是叶子节点,输出2。

输入

第一行:1个数n(1 < n <= 1000),表示树的节点数量。 后面n-1行:每行2个数x y,表示节点x是节点y的父节点(1 <= x, y <= n)。

输出

输出1个数,表示这棵树有多少个叶子节点。

输入样例

5
1 2
1 3
2 4
4 5

输出样例

2

代码

#include<bits/stdc++.h>

#define N 1005
using namespace std;

struct Node {
    vector<Node *> children;
};

Node *nodeList[N]{nullptr};

int main() {
    int n;
    cin >> n;
    nodeList[1] = new Node;
    for (int i = 2, parent, child; i <= n; i++) {
        cin >> parent >> child;
        if (!nodeList[child]) nodeList[child] = new Node;
        nodeList[parent]->children.push_back(nodeList[child]);
    }
    queue<Node *> que;
    que.push(nodeList[1]);
    int result = 0;
    while (!que.empty()) {
        auto cur = que.front();
        que.pop();
        if (cur->children.empty()) result++;
        for (auto &i : cur->children) que.push(i);
    }
    cout << result;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值