Tree of Tree (树形DP)

原题目:

You're given a tree with weights of each node, you need to find the maximum subtree of specified size of this tree.

Tree Definition
A tree is a connected graph which contains no cycles.

 

Input

 

There are several test cases in the input.

The first line of each case are two integers N(1 <= N <= 100), K(1 <= K <= N), where N is the number of nodes of this tree, and K is the subtree's size, followed by a line with N nonnegative integers, where the k-th integer indicates the weight of k-th node. The following N - 1 lines describe the tree, each line are two integers which means there is an edge between these two nodes. All indices above are zero-base and it is guaranteed that the description of the tree is correct.

 

Output

 

One line with a single integer for each case, which is the total weights of the maximum subtree.

 

Sample Input

 

3 1
10 20 30
0 1
0 2
3 2
10 20 30
0 1
0 2

 

Sample Output

 

30
40

中文概要:

给你一棵树,每个点(树叶和结点)都有一个权值,求一拥有个K个节点的子树 的权值和最大为多少

           输入: 点数n,节点数 k

           输出:K个节点的子树 的最大权值


#include<cstdio>

#include<cstring>

#include<vector>

#include<algorithm>

using namespace std;

 

const int maxn = 110;

vector<int>v[maxn];

int dp[maxn][maxn];

int visit[maxn];

int n,m;

 

void DFS(int x)

{

    visit[x]=1;

    for(int i=0;i<v[x].size();i++){

        int d=v[x][i];

        if(!visit[d]){

            DFS(d);

            for(int j=m;j>=1;j--){   //因为m的取值 至少是 1,就是结点自己本身

                for(int k=1;k<j;k++)//至少从自身取一个结点,所以最多从 x 的子结点 d 中取 j-1个

                    dp[x][j] = max( dp[x][j], dp[x][k]+dp[d][j-k] ); //如果之前找到最大值了,那么就不会更新了

            }

        }

    }

}

 

int main()

{

    while(scanf("%d%d",&n,&m)!=EOF){

        for(int i=0;i<n;i++){

	    v[i].clear();

	    visit[i]=0;

        }

        memset(dp,0,sizeof(dp));

        for(int i=0;i<n;i++){

            scanf("%d",&dp[i][1]);

        }

	int a,b;

        for(int i=0;i<n-1;i++){

            scanf("%d%d",&a,&b);

            v[a].push_back(b);//添加一条边,双向关联

            v[b].push_back(a);

        }

        DFS(0);

	int ans=0;

	for(int i=0;i<n;i++)

	    if(dp[i][m]>ans) ans = dp[i][m];//更新 以 每个点  为树根的k结点子树的最大值  

        printf("%d\n",ans);

    }

    return 0;

}

思路:
dp[x][j] = max( dp[x][j], dp[x][k]+dp[d][j-k] )   这一句是关键,表示 以x 为根节点 且 节点数(包含自身)为j 的数的和的最大值,他的值会在以子树为根时 进行更新。自身(不包含d儿子的其他点)取k个,从子树(d儿子)中取j-k个。
这是这道题最重要的地方

感觉跟区间DP有点像。。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值