(kuangbin带你飞--基础DP)Tickets HDU1260

原题目:

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

中文概要:

每组输入一个n表示有n个时间 ,接下来输入n个数a[ ],对应n个人每个人的时间,再输入n-1个数b[ ],表示相邻两个人一块所需的时间。求最小时间。

#include <iostream>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string.h>
#include<bits/stdc++.h> 
using namespace std;
int main()
{
	int a[10005],b[10005],dp[10005];
	int T,n,sum,s,m,h;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
	}
	    for(int i=2;i<=n;i++)
	    {
	    	scanf("%d",&b[i]);
		}
		dp[1]=a[1];
		for(int i=2;i<=n;i++)
		{
			dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
		}
		sum=dp[n];//sum为所需要的总时间 
		s=0;m=0;h=0;
		if(sum>60)
		{
			s=sum%60;
			m=(sum-m)/60;
			h=m/60;
			m=m%60;
		}
		else
		{
			s=sum;
		}
		h+=8;
		if(h>12)
		printf("%02d:%02d:%02d pm\n",h,m,s);
		else
		printf("%02d:%02d:%02d am\n",h,m,s);
    }
    return 0;
}

思路:

用dp数组存储最小时间。例如a[1]=1,a[2]=2,a[3]=3...b[2]=2,b[3]=3.先使a[1]+a[2]与b[2]比较,取最小为dp[2];然后让dp[2]+a[3]与a[1]+b[3]比较,取最小为dp[3]。依次向后运算,则dp[n]为最小时间。

这个一定要自己手写一下算一下马上就出来了,当时看半天不清楚手一划就明白了,比如举例前三人最小值得话,

用a来表示     a[1],a[2],a[3]

用b来表示      b[2],b[3],

要先算出前两人的最小值,则要比较a[1]+a[2]与b[2]的值,选出最小的并赋值给dp[2]

而前三人就是a[1]+b[3](b[3]==a[1]+a[2])与b[2]+a[3]的值进行比较,取最小的赋值给dp[3],

这样递推式就轻而易举写出来是

dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);

后面就是算时间,总时间sum=dp[n]就可

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值