day3 POJ - 1611

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
题目大意就是一共有n个学生,m个团队,每个团队有不同编号的学生参加,0编号表示感染体,感染体在的团体都是嫌疑人,嫌疑人在的团体也都是嫌疑人,一个有多少个嫌疑人,包含感染体;
简单的并查集:用每个团体的第一个人表示领队,其他人都是分支,然后通过找和0编号有共同关系的其他编号

#include<iostream>
#include<iomanip>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int pre[40001];
int x1;
int x2, w,bb,aa;

int kk(int root)
{
	int son=root,tmp;
	while(root!=pre[root])
		root=pre[root];
	while(son!=root)
	{
		tmp=pre[son];
		pre[son]=root;
		son=tmp;
	}
	return root;
}
int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		if(n==0)
			return 0;
		for(int i=0;i<=n;i++)
			pre[i]=i;
		for(int i=1;i<=m;i++)
		{
			cin>>w>>bb;
			x1=kk(bb);
			for(int j=1;j<w;j++)
			{
				cin>>aa;
				x2=kk(aa);
				if(x1!=x2)
				{
					pre[x2]=x1;
				}
			}
		}
		int aaa=0;
			for(int i=0;i<=n;i++)
			{
				
			if(kk(i)==kk(0))
			aaa++;
			}
			cout<<aaa<<endl;
	}
		
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值