Super Mario HDU - 4417(主席树)(求小于k的多少个)

Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.
Input
The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
Output
For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.
Sample Input
1
10 10
0 5 2 7 5 4 3 8 7 7
2 8 6
3 5 0
1 3 1
1 9 4
0 1 0
3 5 5
5 5 1
4 6 3
1 5 7
5 7 3
Sample Output
Case 1:
4
0
0
3
1
2
0
1
5
1

被zx学长秀了一脸

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=200106;
int a[maxn];
int id[maxn];
int root[maxn];
int tot;
int n,m;
const int inf=0x3f3f3f3f;

struct sgt{
	int lc,rc;
	int dat;
}t[maxn*21];

int build(int l,int r){
	int p=++tot;
	t[p].dat=0;
	if(l==r){
		return p;
	}
	int mid=(l+r)/2;
	t[p].lc=build(l,mid);
	t[p].rc=build(mid+1,r);
	return p; 
}

int insert(int now,int l,int r,int x){
	int p=++tot;
	t[p]=t[now];
	
	if(l==r) {
		t[p].dat++;
		return p;		
	} 
	int mid=(l+r)/2;
	if(x<=mid) t[p].lc=insert(t[now].lc,l,mid,x);
	else t[p].rc=insert(t[now].rc,mid+1,r,x);
	t[p].dat=t[t[p].lc].dat+t[t[p].rc].dat;
	return p;
}

int query(int pl,int pr,int l,int r,int k){
	if(l==r) return t[pr].dat-t[pl].dat;
	int mid=(l+r)/2;
	int tem=t[t[pr].lc].dat-t[t[pl].lc].dat;
	if(k<=mid) return query(t[pl].lc,t[pr].lc,l,mid,k);
	else return tem+query(t[pl].rc,t[pr].rc,mid+1,r,k);
}





int main(){
	int ca;
	scanf("%d",&ca);
	int ct=1;
	while(ca--){
		printf("Case %d:\n",ct++);
		tot=0;	
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
			id[i+1]=a[i];
		}
		id[1]=-inf;
		id[n+2]=inf;
		sort(id+1,id+n+3);
		int len=unique(id+1,id+3+n)-(id+1); 
		root[0]=build(1,len);
		for(int i=1;i<=n;i++){
			int p=lower_bound(id+1,id+1+len,a[i])-id;
			root[i]=insert(root[i-1],1,len,p);
		}
		for(int i=1;i<=m;i++){
			int tl,tr,k;
			scanf("%d%d%d",&tl,&tr,&k);
			tl++;
			tr++;
			printf("%d\n",query(root[tl-1],root[tr],1,len,upper_bound(id+1,id+len+1,k)-id-1));
		}
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值