POJ3414(Pots)

Pots

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4
Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

思路

倒水问题,比杭电那个非常可乐要简单一点。这是一个special judge,操作比较简单

  1. FILL(i) 将第i个容器从水龙头里装满(1 ≤ i ≤ 2);
  2. DROP(i) 将第i个容器抽干
  3. POUR(i,j) 将第i个容器里的水倒入第j个容器(这次操作结束后产生两种结果,一是第j个容器倒满并且第i个容器依旧有剩余,二是第i个容器里的水全部倒入j中,第i个容器为空)
    写好状态转移,数值都比较小判重也简单。
#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
#include <algorithm>
using namespace std;
struct node{
	int x,y,t;
	int f[200];
};
queue<node>q;
bool visited[10000];
void bfs(int a,int b,int c)
{
	while(!q.empty()){
		node ptr = q.front(),p;
		q.pop();
		if(ptr.x == c || ptr.y == c){
			printf("%d\n",ptr.t);
			for(int i = 1;i <= ptr.t;i++){
				if(ptr.f[i] == 1){
					printf("FILL(1)\n");
				}
				if(ptr.f[i] == 2){
					printf("FILL(2)\n");
				}
				if(ptr.f[i] == 3){
					printf("DROP(1)\n");
				}
				if(ptr.f[i] == 4){
					printf("DROP(2)\n");
				}
				if(ptr.f[i] == 5){
					printf("POUR(1,2)\n");
				}
				if(ptr.f[i] == 6){
					printf("POUR(2,1)\n");
				}
			}
			return ;
		}
		p = ptr;
		for(int i = 0;i < 6;i++){
			if(i == 0){				//给a加满 
				p.x = a;
				p.y = ptr.y;
				int t = p.x*100+p.y;
				if(visited[t] == false){
					p.t = ptr.t + 1;
					p.f[p.t] = 1;
					visited[t] = true;
					q.push(p);
				}
			}
			if(i == 1){				//给b加满 
				p.x = ptr.x;
				p.y = b;
				int t = p.x*100+p.y;
				if(visited[t] == false){
					p.t = ptr.t + 1;
					p.f[p.t] = 2;
					visited[t] = true;
					q.push(p);
				}
			}
			if(i == 2){				//把a倒掉 
				p.x = 0;
				p.y = ptr.y;
				int t = p.x*100+p.y;
				if(visited[t] == false){
					p.t = ptr.t + 1;
					p.f[p.t] = 3;
					visited[t] = true;
					q.push(p);
				}
			}
			if(i == 3){				//把b倒掉 
				p.x = ptr.x;
				p.y = 0;
				int t = p.x*100+p.y;
				if(visited[t] == false){
					p.t = ptr.t + 1;
					p.f[p.t] = 4;
					visited[t] = true;
					q.push(p);
				}
			}
			if(i == 4){				//a给b倒 
				if(ptr.y < b){
					if(ptr.x <= b - ptr.y){
						p.x = 0;
						p.y = ptr.x + ptr.y;
					}
					else{
						p.x = ptr.x - (b - ptr.y);
						p.y = b;
					}
					int t = p.x*100+p.y;
					if(visited[t] == false){
						p.t = ptr.t + 1;
						p.f[p.t] = 5;
						visited[t] = true;
						q.push(p);
					}
				}
			}
			if(i == 5){				//b给a倒 
				if(ptr.x < a){
					if(ptr.y <= a - ptr.x){
						p.x = ptr.x + ptr.y;
						p.y = 0;
					}
					else{
						p.x = a;
						p.y = ptr.y - (a - ptr.x);
					}
					int t = p.x*100+p.y;
					if(visited[t] == false){
						p.t = ptr.t + 1;
						p.f[p.t] = 6;
						visited[t] = true;
						q.push(p);
					}
				}
			}
		}
	}
	printf("impossible\n");
}
int main()
{
	int a,b,c;
	while(~scanf("%d%d%d",&a,&b,&c)){
		while(!q.empty()){
			q.pop();
		}
		node p;
		p.x = 0;p.y = 0;p.t = 0;
		memset(p.f,0,sizeof(p.f));
		memset(visited,0,sizeof(visited));
		q.push(p);
		bfs(a,b,c);
	}
	return 0;
}

愿你走出半生,归来仍是少年~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值