Pots(bfs恶心的宽搜)

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

题目大意:把i容器装满水, DROP(i): 将i容器水全部倒掉,
         POUR(i,j): 从容器i向容器j倒水, 当i的水大于j的剩余容量时, j倒满,i可以剩余.
         输入A,B,C: 2个容器的容量和目标容量. 只要其中一个容器的水是C就是解.
解题思路:
                1. 判定是否有解. ax + by = gcd(a,b); 即: C % gcd(a,b) == 0 有解.
                2. 寻找最短路广搜咯.

题目链接:http://poj.org/problem?id=3414

源代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<stack>
#include<queue>
#include<math.h>
using namespace std;
struct node{
    int a;
    int b;
    string path;
    int step;
}star,st;
bool vis[200][200];
int A,B,d,C,l;
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
void print()
{
    printf("%d\n",st.step);
    for(int i=0;i<st.step;i++)
    {
        switch(st.path[i])
        {
            case '0':printf("FILL(1)\n");break;
            case '1':printf("FILL(2)\n");break;
            case '2':printf("DROP(1)\n");break;
            case '3':printf("DROP(2)\n");break;
            case '4':printf("POUR(1,2)\n");break;
            case '5':printf("POUR(2,1)\n");break;
            default:break;
        }
    }
}
void bfs()
{
    queue<node> p;
    p.push(star);
    while(!p.empty())
    {
        st=p.front();
        p.pop();
        if(st.a==C||st.b==C)
        {
            print();
            return ;
        }
        int i;
         for(int i = 0; i < 6; ++i)
        {
            if(i == 0)
            {
                node tt = st;
                tt.a = A;
                if(!vis[tt.a][tt.b])
                {
                    vis[tt.a][tt.b] = true;
                    tt.path += '0';
                    tt.step++;
                    p.push(tt);
                }
            }
            else if(i == 1)
            {
                node tt = st;
                tt.b = B;
                if(!vis[tt.a][tt.b])
                {
                    vis[tt.a][tt.b] = true;
                    tt.path += '1';
                    tt.step++;
                    p.push(tt);
                }
            }
            else if(i == 2)
            {
                node tt = st;
                tt.a = 0;
                if(!vis[tt.a][tt.b])
                {
                    vis[tt.a][tt.b] = true;
                    tt.path += '2';
                    tt.step++;
                    p.push(tt);
                }
            }
            else if(i == 3)
            {
                node tt = st;
                tt. b = 0;
                if(!vis[tt.a][tt.b])
                {
                    vis[tt.a][tt.b] = true;
                    tt.path += '3';
                    tt.step++;
                    p.push(tt);
                }
            }
            else if(i == 4)
            {
                node tt = st;
                if(tt.a > B-tt.b)
                {
                    tt.a -= (B-tt.b);
                    tt.b = B;
                }
                else
                {
                    tt.b += tt.a;
                    tt.a = 0;
                }
                if(!vis[tt.a][tt.b])
                {
                    vis[tt.a][tt.b] = true;
                    tt.path += '4';
                    tt.step++;
                    p.push(tt);
                }
            }
            else if(i == 5)
            {
                node tt = st;
                if(tt.b > A-tt.a)
                {
                    tt.b -= (A-tt.a);
                    tt.a = A;
                }
                else
                {
                    tt.a += tt.b;
                    tt.b = 0;
                }
                if(!vis[tt.a][tt.b])
                {
                    vis[tt.a][tt.b] = true;
                    tt.path += '5';
                    tt.step++;
                    p.push(tt);
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d%d",&A,&B,&C))
    {
        if(C%gcd(A,B)!=0)
        {
            printf("impossible\n");
        }
        else
        {
            l=0;
            d=0;
            memset(vis,false,sizeof(vis));
            star.a=0;
            star.b=0;
            star.step=0;
            star.path="";
            bfs();
        }
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值