POJ2251(Dungeon Master)

Dungeon Master

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input

3 4 5
S…
.###.
.##…
###.#

##.##
##…

#.###
####E

1 3 3
S##
#E#

0 0 0
Sample Output

Escaped in 11 minute(s).
Trapped!

思路

三维迷宫模板题一道,直接暴力拓展8个方向找到就是最短时间退出即可,没啥技术含量。地图读入建议直接一行一行读入

#include <iostream>
#include <queue>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node{
	int x,y,z,step;
};
const int maxn = 35;
int dx[] = {1,-1,0,0,0,0};
int dy[] = {0,0,1,-1,0,0};
int dz[] = {0,0,0,0,1,-1};
char map[maxn][maxn][maxn];
queue<Node>q; 
int x,y,z;
int bfs()
{
	while(!q.empty()){
		Node ptr = q.front(),p;
		q.pop();
		for(int i = 0;i < 6;i++){
			p.x = ptr.x + dx[i];
			p.y = ptr.y + dy[i];
			p.z = ptr.z + dz[i];
			if(p.x < 0 || p.x >= x || p.y < 0 || p.y >= y || p.z < 0 || p.z >= z 
				|| map[p.x][p.y][p.z] == '#'){
				continue;		
			}
			p.step = ptr.step + 1;
			if(map[p.x][p.y][p.z] == 'E'){
				return p.step;
			}
			map[p.x][p.y][p.z] = '#';
			q.push(p);
		}
	}
	return -1;
}
int main()
{
	while(~scanf("%d%d%d",&x,&y,&z)){	
	int start_x,start_y,start_z;
		if(x == 0 && y == 0 && z == 0){
			break;
		}
		int flag = 0;
		for(int i = 0;i < x;i++){
			for(int j = 0;j < y;j++){
				scanf("%s",map[i][j]);
				if(flag == 1){
					continue;
				}
				int len = strlen(map[i][j]);
				for(int k = 0;k < len;k++){
					if(map[i][j][k] == 'S'){
						start_x = i;start_y = j;start_z = k;
						flag = 1;
						break;
					}
				}
			}
		}
		while(!q.empty()){
			q.pop();
		}
		Node start;
		start.x = start_x;start.y = start_y;
		start.z = start_z;start.step = 0;
		q.push(start);
		int ans = bfs();
		if(ans == -1){
			printf("Trapped!\n");
		}
		else{
			printf("Escaped in %d minute(s).\n",ans);
		}
	}
	return 0;
}

愿你走出半生,归来仍是少年~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值