POJ1611 The Suspects 并查集模板题

在这里插入图片描述
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

论使用scanf和printf的重要性
(第一行是cin cout加关闭同步,第二行是直接cin cout,第三行是scanf和printf)
(左边那列是time 中间是memory)
在这里插入图片描述

代码:

#include <stdio.h>

using namespace std;

int const N = 3e4+10;
int union_map[N];
int n,m;

int find_root(int curr)
{
	return curr==union_map[curr]?curr:union_map[curr]=find_root(union_map[curr]);
}

int main()
{
	while(scanf("%d%d", &n, &m)&& (n || m))
	{
		for(int i=0;i<=n;i++)
			union_map[i]=i;
		for(int i=0;i<m;i++)
		{
			int num;
			scanf("%d",&num);
			int x,y;
			for(int j=1;j<=num;j++)
			{
				scanf("%d", &y);
				if (j == 1) {
					x = y;
					continue;
				}
				int tx = find_root(x);
				int ty = find_root(y);
				if(tx>ty)
					union_map[tx]=ty;
				else
					union_map[ty] = tx;
			}
		}
		int counter=0;
		for(int i=0;i<n;i++)
		{
			if(0==find_root(i))
				counter++;
		}
		printf("%d\n", counter);
	}
	
	
	return 0;
 } 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值