Escape(二分图多重匹配)

Problem

2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.

Input

More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most…
0 <= ai <= 100000

Output

Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.

Sample Input

1 1
1
1

2 2
1 0
1 0
1 1

Sample Output

YES
NO

题意

2012如果这是世界末日怎么办?我不知道怎么。但是现在科学家发现,有些恒星可以生存,但有些人不适合生活在某些星球上。现在,科学家想要您的帮助,就是确定所有人都可以住在这些星球上。
n表示地球上有n个人,m代表m行星,行星和人标签是从0开始的。然后n行,每行代表一个人的合适生活条件,每行有m个数字,第i个数字为1,表示一个人适合生活在第i行星中,或者对于0表示这个人不适合住在第i个星球。
最后一行包含m个数字,第i个数字ai表示第i个星球最多可以容纳ai人。

代码
#include<cstring>
#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;
const int maxn = 100010, maxm = 12;
bool mp[maxn][maxm], vis[maxm];
int link[maxm][maxn], limit[maxm], cnt[maxm];
int m, n;

bool find(int k) {
    for (int i = 0; i < m; i++) {
        if (mp[k][i] && !vis[i]) {
            vis[i] = true;
            if (cnt[i] < limit[i]) {
                link[i][cnt[i]++] = k;
                return true;
            }
            for (int j = 0; j < limit[i]; j++) {
                if (find(link[i][j])) {
                    link[i][j] = k;
                    return true;
                }
            }
        }
    }
    return false;
}

int main() {
    //解除的是C++运行库层面的对数据传输的绑定,取消输入输出时数据加入缓存,以提高效率
    ios::sync_with_stdio(0);
    cin.tie(0);
    cout.tie(0);
    while (cin >> n >> m) {
        if (n == -1) {
            break;
        }
        memset(link, 0, sizeof(link));
        memset(cnt, 0, sizeof(cnt));
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                cin >> mp[i][j];
            }
        }
        for (int i = 0; i < m; i++) {
            cin >> limit[i];
        }
        int i;
        for (i = 0; i < n; i++) {
            memset(vis, 0, sizeof(vis));
            if (!find(i)) {
                break;
            }
        }
        if (i == n) {
            cout << "YES\n";
        } else {
            cout << "NO\n";
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值