二叉搜索树的结构

L3-016 二叉搜索树的结构 (30 分)
二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)

给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。

输入格式:
输入在第一行给出一个正整数N(≤100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(≤100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:

A is the root,即"A是树的根";
A and B are siblings,即"A和B是兄弟结点";
A is the parent of B,即"A是B的双亲结点";
A is the left child of B,即"A是B的左孩子";
A is the right child of B,即"A是B的右孩子";
A and B are on the same level,即"A和B在同一层上"。
题目保证所有给定的整数都在整型范围内。

输出格式:
对每句陈述,如果正确则输出Yes,否则输出No,每句占一行。

输入样例:
5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3
输出样例:
Yes
Yes
Yes
Yes
Yes
No
No
No

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <map>
using namespace std;
int data[105],le[105],rig[105];
int fa[105],level[105];
int root;
map<int,int> m;
void add(int &r,int father,int depth,int loc){
	if(r == -1){
		r = loc;
		fa[loc] = father;
		level[loc] = depth;
		return;
	}
	if(data[loc] < data[r]){
		add(le[r],r,depth + 1,loc);
	}
	else{
		add(rig[r],r,depth + 1,loc);
	}
}
int main(){
	int n;
	scanf("%d",&n);
	root = -1;
	memset(le,-1,sizeof(le));
	memset(rig,-1,sizeof(rig));
	for(int i = 1;i <= n;i++){
		scanf("%d",&data[i]);
		add(root,-1,1,i);
		m[data[i]] = i;
	}
	int q,a,b;
	string aa;
	bool flag;
	scanf("%d",&q);
	while(q--){
		flag = false;
		scanf("%d",&a);
		cin>>aa;
		if(aa == "is"){
			cin>>aa>>aa;
			if(aa == "root"){
				if(m.find(a) != m.end() && data[root] == a) flag = true;
			}
			else if(aa == "parent"){
				cin >> aa;
				cin >> b;
				if(m.find(a) != m.end() && m.find(b) != m.end() && fa[m[b]] == m[a]) flag = true;
			}
			else if(aa == "left"){
				cin >> aa >> aa;
				cin >> b;
				if(m.find(a) != m.end() && m.find(b) != m.end() && fa[m[a]] == m[b] && a < b) flag = true;
			}
			else{
				cin >> aa >> aa;
				cin >> b;
				if(m.find(a) != m.end() && m.find(b) != m.end() && fa[m[a]] == m[b] && a > b) flag = true;
			}		
		}
		else{
			cin >> b;
			cin >> aa >> aa;
			if(aa == "siblings"){
				if(m.find(a) != m.end() && m.find(b) != m.end() && fa[m[a]] == fa[m[b]]) flag = true;
			}
			else{
				cin >> aa >> aa >> aa;
				if(m.find(a) != m.end() && m.find(b) != m.end() && level[m[a]] == level[m[b]]) flag = true;
			}
		}
		puts(flag?"Yes":"No");
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值