POJ 1129 Channel Allocation(图着色)

Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,…,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output
1 channel needed.
3 channels needed.
4 channels needed.

解题思路:
图着色问题,要求使用最少的机器,因为数据特别小,那么可以遍历图,记录每个点相邻的点所被染的色,然后从已有的颜色中找一个没有的去把当前点染上色,没有的话所需要的颜色总数就要加一.要注意英文输出的单复数。

代码如下:

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long ll;
int vis[30];
struct Edge{
    int to,net;
}e[1005];
int head[30],ans,cnt;
void add(int from,int to){
    e[ans]=Edge{to,head[from]};
    head[from]=ans++;
}
void dfs(int a){
    int res[30];
    memset(res,0,sizeof(res));
    for(int i=head[a];i!=-1;i=e[i].net){//记录每个被染的色,没有被染过色就是0,不影响结果
        res[vis[e[i].to]]=1;
    }
    for(int i=1;i<=26;i++){
        if(res[i]==0){//遍历相邻的点没有哪些颜色
            vis[a]=i;
            cnt=max(cnt,i);//取得所用的最大的,最后得到的就是结果
            return;
        }
    }
}
int main(){
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n&&n!=0){
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        ans=0;
        cnt=1;
        for(int i=0;i<n;i++){
            string s;
            cin>>s;
            int len=s.length();
            for(int j=2;j<len;j++){//连边
                int b=s[j]-'A';
                add(i,b);
                add(b,i);
            }
        }
        for(int i=0;i<n;i++){
            dfs(i);
        }
        cout<<cnt;
        if(cnt==1)cout<<" channel needed.";
        else cout<<" channels needed.";//注意复数要加s
        cout<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值