V - Maximum GCD(读入技巧)

Given the N integers, you have to nd the maximum GCD (greatest common divisor) of every possible

pair of these integers.

Input

The rst line of input is an integerN(1<N<100) that determines the number of test cases.

The followingNlines are theNtest cases. Each test case contains

M(1<M<100) positiveintegers that you have to nd the maximum of GCD.

Output

For each test case show the maximum GCD of every possible pair.

Sample Input

3

10 20 30 40

7 5 12

125 15 25

Sample Output

20

1

25

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
int gcd(int a,int b){return b==0?a:gcd(b,a%b);}
int main()
{
    int t;
    cin>>t;
    getchar();
    char s[1111]; //以字符串的方式读入,要开大点,不过由于数据比较水开100多也能过
    int a[111];
    while(t--)
    {

        gets(s);
        int top=0;
        int len=strlen(s);
        for(int i=0; i<len; i++)
        {
            int sum=0;
            while(i<len&&s[i]!=' ')
            {
                sum=sum*10+s[i]-'0';
                i++;
            }
            a[top++]=sum;  //数据比较水如果最后有多个空格的话,这里会多放0,但是这也过了
        }
        for(int i=0;i<top;i++)
            cout<<a[i]<<" ";
        cout<<endl;
        int ans=0;
        for(int i=0;i<top;i++)
        {
            for(int j=i+1;j<top;j++)
            {
                ans=max(ans,gcd(a[i],a[j]));
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值