V - Maximum GCD UVA - 11827

V - Maximum GCD UVA - 11827
description
Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible
pair of these integers.
Input
The first line of input is an integer N (1 < N < 100) that determines the number of test cases.
The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive
integers that you have to find the maximum of GCD.
Output
For each test case show the maximum GCD of every possible pair.
Sample Input
3
10 20 30 40
7 5 12
125 15 25
Sample Output
20
1
25
题意:给一组数求两个数之间的最大公约数。
题解:直接暴力求即可,需要用sstream流来进行数据的读入。
AC代码:
/*
* @Author: 王文宇
* @Date:   2017-10-28 15:30:11
* @Last Modified by:   王文宇
* @Last Modified time: 2017-10-28 16:50:34
*/
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <sstream>
using namespace std;
const int maxn =107;
int a[maxn];
int t,n;
int b[maxn][maxn];
int gcd(int x,int y)
{
	if(y==0)return x;
	return gcd(y,x%y);
}
int main()
{
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		n=1;
		string s;
		getline(cin,s);
		stringstream ss(s);
		while(ss>>a[n])
			{
				++n;
			}
		int max1 = 0;
		for(int i=1;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
				max1 = max(max1,gcd(a[i],a[j]));
			}
		}
		printf("%d\n",max1 );
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值