数据结构实验之二叉树五:层序遍历

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Sample Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

abcdefg
xnuli

Hint

 

Source

xam

#include<bits/stdc++.h>
using namespace std;
struct node
{
    node *l,*r;
    char data;
};
int top;
char a[100];
node *create()
{
    top++;
    node *root;
    root=new node;
    if(a[top]==',')
        return NULL;
    else
    {
        root->data=a[top];
        root->l=create();
        root->r=create();
    }
    return root;
}
void layershow(node *root)
{
    queue<node*>que;//注意这里是node*,坑死我了
    if(root)        //一定要特判,不然会RE
    {
        que.push(root);
        cout<<que.front()->data;
    }
    while(que.size())
    {
        node *root=que.front(); //常用手段
        que.pop();
        if(root->l)  //依次找左右儿子输出即可
        {
            cout<<root->l->data;
            que.push(root->l);
        }
        if(root->r)
        {
            cout<<root->r->data;
            que.push(root->r);
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>a;
        top=-1;
        node *root;
        root=create();
        layershow(root);
        cout<<endl;
    }
    return 0;
}


/***************************************************
User name: ACM18171信科1801张林
Result: Accepted
Take time: 0ms
Take Memory: 216KB
Submit time: 2019-02-24 22:57:37
****************************************************/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值