迷失の搜索树(先序->后序)

Problem Description

小璐在机缘巧合之下获得了一个二叉搜索树,这个二叉搜索树恰好有n个节点,每个节点有一个权值,每个节点的权值都在[1,n]这个区间内,并且两两不相同,真是优美的性质啊

但是命运的不公又让她失去了这个二叉搜索树

幸运的是,她还记得自己丢失的二叉搜索树的前序遍历序列。

在丢了二叉搜索树之后,小璐无比想念她的这个树的后序遍历

那么问题来了,聪明的你在知道这个二叉搜索树的前序遍历的序列的情况下,能帮她找到这个二叉搜索树的后序遍历嘛?

Input

 多组输入,以文件结尾

每组数据第一行为一个整数n,代表这个二叉搜索树的节点个数(1<=n<=100)

接下来一行n个整数,代表这个二叉搜索树的前序遍历序列

Output

输出n个整数

表示这个二叉树的后序遍历序列

Sample Input

5
4 2 1 3 5

Sample Output

1 3 2 5 4

Hint

 二叉查找树是一棵空树,或者是具有下列性质的二叉树:

若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值

若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值

它的左、右子树也分别为二叉排序树

Source

2016暑假集训结训赛 by QAQ

#include<bits/stdc++.h>
using namespace std;
struct node
{
    node *l,*r;
    int data;
};
node *Insert(node *root,int x)
{
    if(root==NULL)
    {
        root=new node;
        root->data=x;
        root->l=NULL;
        root->r=NULL;
    }
    else if(x<root->data)
        root->l=Insert(root->l,x);
    else
        root->r=Insert(root->r,x);
    return root;
}
int sum;
void visit(node *root)
{
    if(root)
    {
        if(sum==0)
        {
            sum=1;
            cout<<root->data;
        }
        else
            cout<<" "<<root->data;
    }
}
void finallshow(node *root)
{
    if(root)
    {
        finallshow(root->l);
        finallshow(root->r);
        visit(root);
    }
}
int main()
{
    int n;
    while(cin>>n)
    {
        node *root=NULL;
        for(int i=1;i<=n;i++)
        {
            int x;
            cin>>x;
            root=Insert(root,x);
        }
        sum=0;
        finallshow(root);
        cout<<endl;
    }
    return 0;
}


/***************************************************
User name: ACM18171信科1801张林
Result: Accepted
Take time: 12ms
Take Memory: 660KB
Submit time: 2019-02-26 14:33:00
****************************************************/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值