迷失の搜索树
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
小璐在机缘巧合之下获得了一个二叉搜索树,这个二叉搜索树恰好有n个节点,每个节点有一个权值,每个节点的权值都在[1,n]这个区间内,并且两两不相同,真是优美的性质啊
但是命运的不公又让她失去了这个二叉搜索树
幸运的是,她还记得自己丢失的二叉搜索树的前序遍历序列。
在丢了二叉搜索树之后,小璐无比想念她的这个树的后序遍历
那么问题来了,聪明的你在知道这个二叉搜索树的前序遍历的序列的情况下,能帮她找到这个二叉搜索树的后序遍历嘛?
Input
多组输入,以文件结尾
每组数据第一行为一个整数n,代表这个二叉搜索树的节点个数(1<=n<=100)
接下来一行n个整数,代表这个二叉搜索树的前序遍历序列
Output
输出n个整数
表示这个二叉树的后序遍历序列
Example Input
5 4 2 1 3 5
Example Output
1 3 2 5 4
Hint
二叉查找树是一棵空树,或者是具有下列性质的二叉树:
若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值
若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值
它的左、右子树也分别为二叉排序树
#include <stdio.h>
int cnt,n,a[1100];
struct node
{
int data;
struct node *l, *r;
};
struct node *creat(int x, struct node *root)
{
if(!root)//如果树为空 或者 找到合适的位置 新建 根或叶子结点
{
root = new node;
root->data = x;
root->l = root->r = NULL;
return root;
}
if( x < root->data)//如果此时值 此时的根节点值小 则向左递归
root->l = creat(x, root->l);
else root->r = creat(x, root->r);
return root;
};
void lastorder(struct node *root)
{
if(root)
{
lastorder(root->l);
lastorder(root->r);
a[cnt++] = root->data;
}
}
int main()
{
while(~scanf("%d", &n))
{
int x;cnt = 0;
struct node *root;
root = NULL;
for( int i = 0; i < n; i++)
{
scanf("%d", &x);
root = creat(x, root);
}
lastorder(root);
for(int i = 0; i < n; i++)
{
if(i) printf(" ");
printf("%d",a[i]);
}
printf("\n");
}
}