G - Seven-Segment Display (思维)

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

The segments of a seven segment display are arranged as a rectangle of two vertical segments on each side with one horizontal segment on the top, middle, and bottom. If we refer the segments as the letters from a to g, it's possible to use the status of the segments which is called a seven segment code to represent a number. A standard combination of the seven segment codes is shown below.

 

Xabcdefg
11001111
20010010
30000110
41001100
50100100
60100000
70001111
80000000
90000100
   
0 = on  1 = off

A seven segment code of permutation p is a set of seven segment code derived from the standard code by rearranging the bits into the order indicated by p. For example, the seven segment codes of permutation "gbedcfa" which is derived from the standard code by exchanging the bits represented by "a" and "g", and by exchanging the bits represented by "c" and "e", is listed as follows.

Xgbedcfa
11011011
20000110
30010010
40011001
50110000
60100000
71011010
80000000
90010000

We indicate the seven segment code of permutation p representing number x as cp, x. For example cabcdefg,7 = 0001111, and cgbedcfa,7 = 1011010.

Given n seven segment codes s1, s2, ... , sn and the numbers x1, x2, ... , xn each of them represents, can you find a permutation p, so that for all 1 ≤ i ≤ n, si = cp,xi holds?

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 ≤ n ≤ 9), indicating the number of seven segment codes.

For the next n lines, the i-th line contains a number xi (1 ≤ xi ≤ 9) and a seven segment code si (|si| = 7), their meanings are described above.

It is guaranteed that ∀ 1 ≤ i < j ≤ n, xi ≠ xj holds for each test case.

Output

For each test case, output "YES" (without the quotes) if the permutation p exists. Otherwise output "NO" (without the quotes).

Sample Input

3
9
1 1001111
2 0010010
3 0000110
4 1001100
5 0100100
6 0100000
7 0001111
8 0000000
9 0000100
2
1 1001111
7 1010011
2
7 0101011
1 1101011

Sample Output

YES
NO
YES

Hint

For the first test case, it is a standard combination of the seven segment codes.

For the second test case, we can easily discover that the permutation p does not exist, as three in seven bits are different between the seven segment codes of 1 and 7.

For the third test case, p = agbfced.

题解:给出标准对应模板,可随意交换2列,交换的次数不限,问是否能满足给出的n个数的正确排列。

我们进行的任意的列变换,行之间的对应关系还是不变的,所以我们只要将给出来n个数按竖直方向记录(将给出来的数用vis标记一下就好了),并同时记录原始状态,最后排序对比一下即可。

#include<bits/stdc++.h>
using namespace std;
int vis[15],suma[15],sumb[15],a[15];
int main()
{
    int t,n,x,y;
    std::ios::sync_with_stdio(0);//超时的话加上这个就行了,或者用scanf
    cin>>t;
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        memset(suma,0,sizeof(suma));
        memset(sumb,0,sizeof(sumb));
        memset(a,0,sizeof(a));
        int b[15]={0,1001111,10010,110,1001100,100100,100000,1111,0,100};//一定要在里面定义~
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>x>>y;
            a[x]=y;
            vis[x]=1;//如果该数出现,将该数标记
        }
        for(int i=1;i<=7;i++)//每一层循环记录对应的数
        {
            for(int j=1;j<=9;j++)//对于9个数字遍历
            {
                if(vis[j])//只有在该数字出现的情况下才记录
                {
                    suma[i]=suma[i]*10+a[j]%10;//按照竖直方向转换成整数
                    sumb[i]=sumb[i]*10+b[j]%10;
                    a[j]/=10;
                    b[j]/=10;
                }
            }
        }
        sort(suma+1,suma+1+7);//排序才能一一对应
        sort(sumb+1,sumb+1+7);
        int flag=1;
        for(int i=1;i<=7;i++)
        {
            if(suma[i]!=sumb[i])
            {
                flag=0;
                break;
            }
        }
        if(flag==0)
            puts("NO");
        else
            puts("YES");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值