B - Dining ( 网络最大流应用 )

B - Dining ( 网络最大流应用 )

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

 

题意:有N头牛,F种食物,D种饮料,每头牛都有自己喜欢的食物和饮料,每种饮料和食物只能分配给一头牛。问:最多有多少头牛能同时得到自己喜欢的食物和饮料。

思路:最大流建图是把食物和饮料放在两端。一头牛拆分成两个点,两点之间的容量为1.喜欢的食物和饮料跟牛建条边,容量为1.加个源点和汇点。源点与食物、饮料和汇点的边容量都是1,表示每种食物和饮料只有一个。这样话完全是最大流问题了。

建图:从源点向每个食物连一条边,容量为1,
将牛拆成两个点牛,牛',中间连边,容量为1
从食物向牛连边,容量为1
连牛'和饮料,容量为1
连饮料和汇点,容量为1

源点-->food-->牛(左)-->牛(右)-->drink-->汇点

图解:

再加上食物饮料和牛的关系,跑一边源点到汇点的最大流dinic算法就得到答案了。

 

代码:

#include <iostream>
#include <queue>
#include <cstring>
#include <stdio.h>

using namespace std;

struct node {
    int to,w,nxt;
};
const int maxn = 2e5+10;
node e[maxn];
int n,f,d;
int head[maxn];
int dep[maxn];
int cnt;

void addage( int u, int v, int w )
{
    e[cnt].to = v;
    e[cnt].w = w;
    e[cnt].nxt = head[u];
    head[u] = cnt++;
}

int bfs(int node) // bfs分层
{
    memset(dep,0,sizeof(dep)); // dep 层的深度
    dep[node] = 1;
    queue <int> Q;
    Q.push(node);
    while ( !Q.empty() ) {
        int x = Q.front();Q.pop();
        for ( int i=head[x]; i!=-1; i=e[i].nxt ) {
            int y = e[i].to,w = e[i].w;
            if ( !dep[y] && w ) {
                dep[y] = dep[x] + 1; // 编号++
                Q.push(y);
            }
        }
    }
    return dep[f+d+2*n+1]; // return dep[t] , 如果是0那么说明没有增广路了,退出while
}

int dfs( int x, int flow ) // dfs找增广路
{
    if ( x==f+d+2*n+1 ) {
        return flow;
    }
    int sum = 0;
    for ( int i=head[x]; i!=-1; i=e[i].nxt ) {
        int y = e[i].to, w = e[i].w;
        if ( w && dep[y]==dep[x]+1 ) {
            int t = dfs(y,min(flow,w));// 注意dfs里面的是min(flow,w)
            flow -= t;      // 当前的flow减t
            sum+=t;         // sum加t,就是上面减去的t。
            e[i].w -= t;    // 正向边减t
            e[i^1].w += t;  // 反向边加t
        }
    }
    if ( sum==0 ) { // 如果sum==0,那么这个点之前没有增广路,深度清零
        dep[x] = 0;
    }
    return sum;
}

int main()
{
    int i,j,u,v,w;
    cnt = 0;
    memset(head,-1,sizeof(head));
    cin >> n >> f >> d;
    // 源点0, 食物1~f, 饮料f+1~f+d, 牛f+d+1~f+d+2*n, 汇点f+d+2*n+1
    for ( i=1; i<=f; i++ ) { // 建立源点和食物的关系
        addage(0,i,1);
        addage(i,0,0);
    }
    for ( i=1; i<=d; i++ ) { // 建立饮料与汇点的关系
        addage(f+i,f+d+2*n+1,1);
        addage(f+d+2*n+1,f+i,0);
    }
    for ( i=f+d+1; i<=f+d+2*n; i+=2 ) { // 建立牛之间的关系
        addage(i,i+1,1);
        addage(i+1,i,0);
    }
    for ( i=0; i<n; i++ ) {
        int ai,bi,x;
        cin >> ai >> bi;
        for ( j=0; j<ai; j++ ) { // 建立食物和左牛的关系
            cin >>x;
            addage(x,f+d+1+2*i,1);
            addage(f+d+1+2*i,x,0);

        }
        for ( j=0; j<bi; j++ ) { // 建立右牛和饮料的关系
            cin >>x;
            addage(f+d+2+2*i,f+x,1);
            addage(f+x,f+d+2+2*i,0);
        }
    }

    int ans = 0;
    while ( bfs(0) ) { // 如果还存在增广路继续
        ans += dfs(0,0x3f3f3f3f); // 加一条增广路的值
    }
    printf("%d\n",ans);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值