H - Can you answer these queries? (线段树)

H - Can you answer these queries? (线段树)

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help. 
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. 

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF. 
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000) 
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63. 
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000) 
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive. 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

题意:一个数列有两种操作,1.区间 [ L,R ] 里所有数开平方, 2.查询区间 [ L,R ] 的和。

思路:没法用lazy,但用普通的线段树会TLE,这里需要另一种优化方式,根据题意,如果一个数已经是1了那么他的开平方也还是1,那么推导出 if ( tree[node]==right-left+1 ) return ;

注:题目没说L,R的大小关系,不能想当然的认为L<R,需要自己加判断。 

 

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#define mid ((left+right)>>1)
#define lson node*2,left,mid
#define rson node*2+1,mid+1,right
typedef long long ll;

using namespace std;

const int maxn = 1e5 + 10;
ll a[maxn*4];
ll tree[maxn*4];
ll n,m;

void up( ll node )
{
    tree[node] = tree[node*2] + tree[node*2+1];
}

void built( ll node, ll left, ll right )
{
    if ( left==right ) {
        tree[node] = a[left];
        return ;
    }
    built(lson);
    built(rson);
    up(node);
}

void update( ll node, ll left, ll right, ll L, ll R )
{
    if ( tree[node]==right-left+1 ) { // 优化
        return ;
    }
    if ( left==right ) {
        tree[node] = sqrt(tree[node]);
        return ;
    }

    if ( L<=mid ) {
        update(lson,L,R);
    }
    if ( R>mid ) {
        update(rson,L,R);
    }
    up(node);
}

ll query( ll node, ll left, ll right, ll L, ll R )
{
    if ( R<left||L>right ) {
        return 0;
    }
    else if ( left>=L&&right<=R ) {
        return tree[node];
    }

    ll sum = 0;
    if ( L<=mid ) {
        sum += query(lson,L,R);
    }
    if ( R>mid ) {
        sum += query(rson,L,R);
    }
    return sum;
}

int main()
{
    ios::sync_with_stdio(0);
    ll i,j,ji=1,L,R,str;
    while ( cin>>n ) {
        memset(tree,0,sizeof(tree));
        for ( i=1; i<=n; i++ ) {
            cin >> a[i];
        }
        built(1,1,n);
        cin >> m;
        cout << "Case #" << ji++ << ":" << endl;
        for ( i=1; i<=m; i++ ) {
            cin >> str >> L >> R;
            if ( L>R ) {
                swap(L,R);
            }
            if ( str==0 ) {
                update(1,1,n,L,R);
            }
            else if ( str==1 ) {
                cout << query(1,1,n,L,R) << endl;
            }
        }
        cout << endl;
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值