Sliding Window(线段树)

Sliding Window

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input
8 3
1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7

题意分析

有两个数n,m,有n个数,从第一位数开始,到第n-m+1位数,求第1-m之间最大值最小值,求第2-m+1之间最大值,直到第n-m+1与n之间最大值与最小值。

思路

通过线段树维护最大值最小值,之后使用for循环不断查找。

代码如下
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
int mintree[5000000];
int maxtree[5000000];
int sum[1000000];
void build(int i,int l, int r)
{
	if (l == r)
	{
		mintree[i] = sum[l];
		maxtree[i] = sum[l];
		return;
	}
	int mid = (l + r) >> 1;
	build(i << 1, l, mid);
	build(i << 1 | 1, mid + 1, r);
	mintree[i] = min(mintree[i << 1], mintree[i << 1 | 1]);
	maxtree[i] = max(maxtree[i << 1], maxtree[i << 1 | 1]);
}
int maxfind(int l, int r, int left, int right, int i)
{
	if (left <= l && right >= r)
	{
		return maxtree[i];
	}
	int mid = (l + r) >> 1;
	int ret = -999999999;
	if (left <= mid)
	{
		ret = max(ret, maxfind(l, mid, left, right,i << 1));
	}
	if (right > mid)
	{
		ret = max(ret,maxfind(mid + 1, r, left, right, i << 1 | 1));
	}
	return ret;
}
int minfind(int l, int r, int left, int right, int i)
{
	if (left <= l && right >= r)
	{
		return mintree[i];
	}
	int mid = (l + r) >> 1;
	int ret = 999999999;
	if (left <= mid)
	{
		ret = min(ret, minfind(l, mid, left, right, i << 1));
	}
	if (right > mid)
	{
		ret = min(ret, minfind(mid+1, r, left, right, i << 1|1));
	}
	return ret;
}
int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &sum[i]);
		}
		build(1, 1, n);
		for (int i = 1; i <= n - m + 1; i++)
		{
			printf("%d ", minfind(1, n, i, i + m-1, 1));
		}
		printf("\n");
		for (int i = 1; i <= n - m + 1; i++)
		{
			printf("%d ", maxfind(1, n, i, i + m-1, 1));
		}
		printf("\n");
	}
	
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值