ZOJ 1789 The Suspects(经典并查集)

The Suspects

题目传送门~

Time Limit: 2000 msMemory Limit: 65536 KB

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.


Input

The input contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n-1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.


Output

For each case, output the number of suspects in one line.


Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0


Sample Output

4
1
1


题后两句话:

①本题是并查集经典问题,三个关键,find函数、merge函数和输入输出的组织。

②这题其实就是并查集的基础框架,一些小细节跟随自己编程习惯调整好就行。

③我是在原有基础上进行了路径压缩和降维合并,然后memset函数呀,输入判断这些小东西就大家自己领悟啦~


话不多说,上才艺!

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int father[30002];
int n,m; 

int find(int x){
	int r=x;
	while(father[r]>=0) r=father[r];
	while(x!=r){
		int ans=father[x];
		father[x]=r;
		x=ans;
	}//路径压缩 
	return r;
}

void merge(int x,int y){//降维合并 
	int fx,fy;
	fx=find(x);
	fy=find(y);
	int temp=father[fx]+father[fy];
	if(fx!=fy){
		if(father[fx]>father[fy]){//由于树根的节点是负值,所以值越大则对应的集合元素越少 
			father[fy]=temp;
			father[fx]=fy;
		}
		else{
			father[fx]=temp;
			father[fy]=fx;
		}
	}
} 

int main()
{
	while((scanf("%d%d",&n,&m)!=EOF),(n+m)){
		memset(father,-1,sizeof(father));//初始化 
		while(m--){
			int num,a,b;
			scanf("%d%d",&num,&a);
			while(--num){
				scanf("%d",&b);
				merge(a,b);
			}			
		}
		cout<<-father[find(0)]<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值