ZOJ 1406 Jungle Roads

Jungle Roads

题目传送门~

Time Limit: 2000 msMemory Limit: 65 

536 KB

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.


Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0


Sample Output

216
30


这题A的就挺容易的嘻嘻嘻嘻...


题后两句话: 

①图论的第一题啊哈哈哈哈,有点水的,很快就A掉了

②并查集维护查询,kurskal算法求取mincost,sort排序,感觉这题用优先队列就有点矫情了,考完试试试吧~


继续加油哦~上代码啦

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=520;

struct edge{
	int u,v; int cost;
	bool operator <(const edge &e) const{ return cost<e.cost; }
}map[maxn];

int father[maxn];

//组织输入
void Init(int num,int &ans){
	char x[2],y[2];
	int temp,val;
	while(num--){
		scanf("%s%d",x,&temp);  //先输入起始点以及连接点的数量
		while(temp--){
			scanf("%s%d",y,&val);  //再逐一输入连接点和边的权值
			
			map[ans].u=x[0]-'@';   
			map[ans].v=y[0]-'@';
			map[ans++].cost=val;
		} 
	}
	sort(map,map+ans);  //把边权值按从大到小的顺序排列(kruskal算法) 
	memset(father,-1,sizeof(father)); 
}

//查找集合根节点
int find(int x){
	int r=x;
	while(father[r]>=0) r=father[r];
	while(x!=r){
		int ans=father[x];
		father[x]=r;
		x=ans;
	}//路径压缩,坍塌规则 
	return r;
}

//降维合并,并且注意这里的merge函数是bool型,判断两个点是否属于同一集合 
bool merge(int x,int y){
	int fx,fy;
	fx=find(x);
	fy=find(y);
	int temp=father[fx]+father[fy];
	if(fx!=fy){
		if(father[fx]>father[fy]){//由于树根的节点是负值,所以值越大则对应的集合元素越少 
			father[fy]=temp;
			father[fx]=fy;
		}
		else{
			father[fx]=temp;
			father[fy]=fx;
		}
		return true;
	}
	return false;
} 

//主函数 
int main()
{
	int n;
	while(~scanf("%d",&n)&&n){
		int ans=0;
		Init(--n,ans);
		
		int mincost=0,count=0;
		
		for(int i=0;i<=ans;i++){
			if(merge(map[i].u,map[i].v)){
				mincost+=map[i].cost;
				count++;
			}
			
			if(count==n) break;  //前面n已经减过了,所以这里只需count==n 
		}
		printf("%d\n",mincost);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值