POJ 3279 Fliptile (暴力枚举+DFS)

p.s. 黑白棋反转问题

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

p.s. 题目大意:给你一个M*N的棋盘,1代表翻转,0代表不翻转,问你怎样才能反转最少的次数让1都变成0,你的每次翻转都会翻转它的上下左右棋子,最后输出你翻转的方式,如果有多种方式,输出字典序最小的,如果不能完成翻转,输出"IMPOSSIBLE"

#include <iostream>
#include <string.h>

using namespace std;

struct node{
    int q,a,z,t;
}now,tmp;

int m,n;
int Map[17][17];
int ans[17][17];
int f[17][17];
int Min;

void dfs(int x,int num)//x代表第x行,num代表翻转次数
{
    if(num>Min)//超过最小翻转次数,舍去此方案
    {
        return;
    }
    if(x>n)//跑完第n行
    {
        int flag=1;
        for(int i=1;i<=m;i++)//判断第n行是否都被翻转
        {
            if((Map[n][i]+f[n][i]+f[n][i-1]+f[n][i+1]+f[n-1][i])%2)
            {
                flag=0;
            }
        }
        if(flag&&num<Min)//如果第n行都被翻转,并且此时num小于最小翻转次数,更新翻转方案
        {
            memcpy(ans,f,sizeof(f));
            Min=num;
        }
        return;
    }
    int t=0;
    for(int i=1;i<=m;i++)
    {
        if((Map[x-1][i]+f[x-2][i]+f[x-1][i-1]+f[x-1][i+1]+f[x-1][i])%2)//判断[x-1][i]是否为1
        {
            f[x][i]=1;
            t++;
        }
        else
        {
            f[x][i]=0;
        }
    }
    dfs(x+1,num+t);
}

void Enum(int y,int num)//y代表第1行第y个棋子,num代表翻转次数,枚举第一行所有情况
{
    if(y>m)
    {
        dfs(2,num);//调用dfs判断第二行以后需要翻转次数
        return;
    }
    f[1][y]=0;
    Enum(y+1,num);
    f[1][y]=1;
    Enum(y+1,num+1);
}

int main()
{
    while(cin >> n >> m)
    {
        Min=0x7f7f7f7f;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin >> Map[i][j];
            }
        }
        Enum(1,0);
        if(Min!=0x7f7f7f7f)
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=m;j++)
                {
                    cout << ans[i][j];
                    if(j!=m)
                    {
                        cout << ' ';
                    }
                    else
                    {
                        cout << endl;
                    }
                }
            }
        }
        else
        {
            cout << "IMPOSSIBLE" << endl;
        }
    }
    return 0;
}

 

POJ 1321 排兵布阵问题可以使用 DFS 算法求解。 题目要求在一个 n x n 的棋盘上,放置 k 个棋子,其中每行、每列都最多只能有一个棋子。我们可以使用 DFS 枚举每个棋子的位置,对于每个棋子,尝试将其放置在每一行中未被占用的位置上,直到放置了 k 个棋子。在 DFS 的过程中,需要记录每行和每列是否已经有棋子,以便在尝试放置下一个棋子时进行判断。 以下是基本的 DFS 模板代码: ```python def dfs(row, cnt): global ans if cnt == k: ans += 1 return for i in range(row, n): for j in range(n): if row_used[i] or col_used[j] or board[i][j] == '.': continue row_used[i] = col_used[j] = True dfs(i + 1, cnt + 1) row_used[i] = col_used[j] = False n, k = map(int, input().split()) board = [input() for _ in range(n)] row_used = [False] * n col_used = [False] * n ans = 0 dfs(0, 0) print(ans) ``` 其中,row 代表当前尝试放置棋子的行数,cnt 代表已经放置的棋子数量。row_used 和 col_used 分别表示每行和每列是否已经有棋子,board 则表示棋盘的状态。在尝试放置棋子时,需要排除掉无法放置的位置,即已经有棋子的行和列,以及棋盘上标记为 '.' 的位置。当放置了 k 个棋子时,即可计数一次方案数。注意,在回溯时需要将之前标记为已使用的行和列重新标记为未使用。 需要注意的是,在 Python 中,递归深度的默认限制为 1000,可能无法通过本题。可以通过以下代码来解除限制: ```python import sys sys.setrecursionlimit(100000) ``` 完整代码如下:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值