PAT菜鸡笔记1003 Emergency

PAT菜鸡笔记1003 Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.
Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4

注意点:

本题是一个根据dijkstra算法做了一丢丢改变的题,需要找到最短路径的数量和最短路径中能叫到最多的帮手数目。实质是找图中每个点到begin的最短路径,当前结点的最短距离就是上一个节点最短距离加上两节点距离和的最小值(是这么理解吧,我觉得)

#include<iostream>
using namespace std;
#define MAX 0x3fffffff
int men[500], len[500][500] = { 0 }, Men[500], num[500] = { 0 };
//num用来记录当前节点到begin节点的最短路径数目
//men记录每个城市的人数
//Men记录当前节点到begin节点的总人数
int d[500] = { 0 }, v[500] = { 0 };
//d记录当前节点到begin节点的最短路径
//v记录当前节点是否被访问过
int main() {
	int n, rodes, begin, end;
	int x, y, l;
	cin >> n >> rodes >> begin >> end;
	for (int i = 0; i < n; i++)
	{
		cin >> men[i];
		Men[i] = men[i];
	}
	for (int i = 0; i < rodes; i++)
	{
		cin >> x >> y >> l;
		len[x][y] = len[y][x] = l;
	}
	for (int i = 0; i < 500; i++)
	{
		if (i != begin)
			d[i] = MAX;
		else
			d[i] = 0;
	}
	x = begin;
	num[x] = 1;
	while (true)
	{
		for(int i=0;i<n;i++)
			if (v[i] == 0 && len[x][i] != 0 )
			{
				if (d[i] > d[x] + len[x][i])
				{
					d[i] = d[x] + len[x][i];
					men[i] = men[x] + Men[i];
					num[i] = num[x];
				}
				else
				{
					if (d[i] == d[x] + len[x][i])
					{
						num[i] += num[x];
						if (men[i] < men[x] + Men[i])
						{
							men[i] = men[x] + Men[i];
						}
					}
			}
			}
		v[x] = 1;
		int t = x;
		for (int i = 0; i < n; i++)
		{
			if(v[i] == 0)
			if (d[i] < d[x]||v[x]==1)
				x = i;
		}
		if (t == x)
			break;
	}
	printf("%d %d", num[end], men[end]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值