A Simple Problem with Integers (POJ-3468)分块(线段树区间更新,区间求和)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

 

题意:输入 n, m表初始有 n 个数, 接下来 m 行输入, Q x y 表示询问区间 [x, y]的和;C x y z 表示区间 [x, y] 内所有数加上 z ;

思路:这道题的话,就是线段树区间更新和区间求和的模板,套一下模板就好了。

AC代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string>
#include <string.h>
#include <math.h>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
typedef long long ll;
const int maxx=100010;
const int inf=0x3f3f3f3f;
using namespace std;
ll sum[maxx<<2];
ll add[maxx<<2];
void push_up(int rt)//向上更新
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void push_down(int rt, int m)//向下更新
{
    if(add[rt])//若有标记,则将标记向下移动一层
    {
        add[rt<<1]+=add[rt];
        add[rt<<1|1]+=add[rt];
        sum[rt<<1]+=(m-(m>>1))*add[rt];
        sum[rt<<1|1]+=(m>>1)*add[rt];
        add[rt]=0;//取消本层标记
    }
}
void build(int l, int r, int rt)//建树
{
    add[rt]=0;
    if(l==r)
    {
        scanf("%lld",&sum[rt]);
        return ;
    }
    int mid=(l+r)>>1;
    build(lson);
    build(rson);
    push_up(rt);//向上更新
}
void update(int x, int y, ll key, int l, int r, int rt)//区间更新
{
    if(l>=x && r<=y)
    {
        sum[rt]+=(r-l+1)*key;
        add[rt]+=key;
        return ;
    }
    push_down(rt,r-l+1);//向下更新
    int mid=(l+r)>>1;
    if(x<=mid)
        update(x,y,key,lson);
    if(y>mid)
        update(x,y,key,rson);
    push_up(rt);//向上更新
}
ll query(int L, int R, int l, int r, int rt)//区间求和
{
    if(l>=L && r<=R)
        return sum[rt];
    push_down(rt,r-l+1);//向下更新
    int mid=(l+r)>>1;
    ll ans=0;
    if(L<=mid)
        ans+=query(L,R,lson);
    if(R>mid)
        ans+=query(L,R,rson);
    return ans;
}
int main()
{
    int n, m;
    scanf("%d%d",&n,&m);
    build(1,n,1);
    while(m--)
    {
        char ch[2];
        int x,y;
        ll z;
        scanf("%s",ch);
        if(ch[0]=='C')
        {
            scanf("%d%d%lld",&x,&y,&z);
            update(x,y,z,1,n,1);
        }
        else
        {
            scanf("%d%d",&x,&y);
            printf("%lld\n",query(x,y,1,n,1));
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值