Girls' research (HDU-3294)

 Girls' research (HDU-3294)

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps: 
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

Input

Input contains multiple cases. 
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase. 
If the length of string is len, it is marked from 0 to len-1.

Output

Please execute the operation following the two steps. 
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!". 
If there are several answers available, please choose the string which first appears.

Sample Input

b babd
a abcd

Sample Output

0 2
aza
No solution!

题意:通过第一个字符与a的关系翻译字符串,输出最长回文串和首尾下标,不存在则输出No solution!

思路:用manachar求出最长回文串中心和半径,因为变换后的串各字符下标改变了,所以输出原首尾下标要公式倒推
输出字符时要跳过插入的符号

AC代码:

#include <bits/stdc++.h>
const int maxx=200010;
const int inf=0x3f3f3f3f;
using namespace std;
char s[maxx];
int p[maxx];
char c;
int main()
{
    while(~scanf("%s%s",&c,s))
    {
        int len=strlen(s);
        for (int i=len; i>=0; i--)
        {
            s[2*i+2]=s[i];
            s[2*i+1]= '#';
        }
        s[0]='$';
        int id=0,reslen=0,rescen=0,mx=0;
        for(int i=1; i<len*2+1; i++)
        {
            p[i]=mx>i?min(p[2*id-i],mx-i):1;
            while(s[p[i]+i]==s[i-p[i]])
                p[i]++;
            if(mx-i<p[i])
            {
                mx=i+p[i];
                id=i;
            }
            if(p[i]-1>reslen)
            {
                reslen=p[i]-1;
                rescen=i;
            }
        }
        if(reslen<2)
        {
            printf("No solution!\n");
            continue;
        }
        int cnt=c-'a';
        int st=(rescen-reslen-1)/2;//st*2+2=reslen-rescen+1
        int en=(rescen+reslen-3)/2;//ed*2+2=reslen+rescen-1
        printf("%d %d\n",st, en);
        for(int i=rescen-reslen+1; i<=rescen+reslen-1; i+=2)
        {
            s[i]-=cnt;
            if (s[i]<'a')
                s[i]+=26;
            printf("%c", s[i]);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值