Hie with the Pie(POJ-3311)(状压DP+Floyd)

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

 

题意:有个人开了一家披萨店,然后他现在需要配送披萨,然后现在给了你这个城市的地图。这个城市的地图就像一个n+1(1<=n<=10)个点的有向完全图,然后用矩阵的形式给出任意两个不同点之间的距离。(其中从i到j的距离不一定等于从j到i的距离)现在要你求出从0号点开始配送,走过1到n号点至少一次,然后再回到0号点所花的最小配送时间。

思路:这道题的话,我们设dp[i][j]表示状态i下以j结尾的最短时间。然后又因为我们不知道每两个点之间到底怎么走时间最短,而且题里还要求每个点至少走一次,所以我们需要用floyd算法求一下最短路程,然后进行dp。

AC代码:

#include <stdio.h>
#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
const int maxx=10010;
const int inf=0x3f3f3f3f;
typedef long long ll;
using namespace std;
int dp[1<<15][15];
int a[15][15];
int n;
void floyd()
{
    for(int k=0; k<n; k++)
    {
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(a[i][j]>a[i][k]+a[k][j])
                    a[i][j]=a[i][k]+a[k][j];
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n),n++)
    {
        memset(dp,inf,sizeof(dp));
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        floyd();
        for(int i=1; i<n; i++)
            dp[1<<i][i]=a[0][i];
        for(int j=0; j<1<<n; j++)
        {
            for(int i=0; i<n; i++)
            {
                if(dp[j][i]!=inf)
                {
                    for(int k=1; k<n; k++)
                    {
                        if(!(j&(1<<k)))
                            dp[j|(1<<k)][k]=min(dp[j][i]+a[i][k],dp[j|(1<<k)][k]);
                    }
                }
            }
        }
        int ans=inf;
        for(int i=1; i<n; i++)
            ans=min(dp[(1<<n)-2][i]+a[i][0],ans);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值