Halloween treats (POJ-3370)(抽屉原理)

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

题意:给出n和m及m个整数(n<m),要从m中找出任意个数使得其和是n的倍数,输出时就输出每一个数所在的编号。

思路:这道题的话,和poj-2356基本一样,看详解的话,看这里:https://blog.csdn.net/weixin_43846139/article/details/105636991

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=100010;
const int inf=0x3f3f3f3f;
const double eps=1e-5;
using namespace std;
int a[maxx];
int mod[maxx];//mod[i]记录sum[i]%n是否出现过,如果以出现,则标记为出现的初始位置
int main()
{
    int c,n;
    while(~scanf("%d%d",&c,&n),c,n)
    {
        ll sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            mod[i]=-2;
        }
        mod[0]=-1;//mod[0]为-1,就是假设存在a[-1],且a[-1]是n的倍数,这样就可以把两种情况写在一起
        for(int i=0; i<n; i++)
        {
            sum+=a[i];
            if(mod[sum%c]!=-2)
            {//如果在i之前有与sum对n同余的数,则可以输出答案
                for(int j=mod[sum%c]+1; j<=i; j++)
                {
                    printf("%d",j+1);
                    if(i!=j)
                        printf(" ");
                }
                printf("\n");
                break;
            }
            mod[sum%c]=i;//将此时对应的余数存到mod中,值为此时的i
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值