E - E.龙皇异次元 (POJ-3723)(最大生成树)

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

题意:现在要征n个男兵和m个女兵,每个花费10000元,但是如果已经征募的男士兵中有和将要征募的女士兵关系好的,那么可以减少花费,给出关系,求最小花费。

思路:这道题的话,初始时候每个人花费是10000元,但如果有关系的话,就可以减去这个关系费。因为我们求的是最小的花费,所以减去的最大即可,又因为每个人只征募一次,即最多选择一个,所以将男生人数和女生人数加在一起乘以10000再减去一个最大生成树即可。

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=50010;
const int mod=10007;
const int inf=0x3f3f3f3f;
const double eps=1e-8;
using namespace std;
int pre[maxx];
struct node
{
    int u;
    int v;
    int w;
} edge[maxx];
bool cmp(node x,node y)
{
    return x.w>y.w;
}
int getf(int x)
{
    if(x==pre[x])
        return pre[x];
    return pre[x]=getf(pre[x]);
}
int Kruskal(int x,int y)
{
    int ans=0;
    for(int i=0; i<x; i++)
        pre[i]=i;
    sort(edge,edge+y,cmp);
    for(int i=0; i<y; i++)
    {
        int fx=getf(edge[i].u);
        int fy=getf(edge[i].v);
        if(fx!=fy)
        {
            ans+=edge[i].w;
            pre[fy]=fx;
        }
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,r;
        scanf("%d%d%d",&n,&m,&r);
        for(int i=0; i<r; i++)
        {
            int x;
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
            edge[i].v+=n;
        }
        int ans=Kruskal(m+n,r);
        printf("%d\n",(n+m)*10000-ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值