G - G (51Nod-1632)(期望)

B国拥有n个城市,其交通系统呈树状结构,即任意两个城市存在且仅存在一条交通线将其连接。A国是B国的敌国企图秘密发射导弹打击B国的交通线,现假设每条交通线都有50%的概率被炸毁,B国希望知道在被炸毁之后,剩下联通块的个数的期望是多少?

Input

一个数n(2<=n<=100000) 接下来n-1行,每行两个数x,y表示一条交通线。(1<=x,y<=n) 数据保证其交通系统构成一棵树。

Output

一行一个数,表示答案乘2^(n-1)后对1,000,000,007取模后的值。

Sample Input

3
1 2
1 3

Sample Output

8

题意:中文题,不过多叙述题意。

思路:这道题的话,题里说要炸毁联通线,因为是树状结构,每炸毁一条联通线,那么强连通分量就会增加1。现在是50%的几率炸毁,那么一半的交通线被炸毁就是\frac{n-1}{2},那么强连通分量的个数就是\frac{n+1}{2}。因为题里最后要乘以2^{n-1},所以最后推导的公式为:ans=\frac{n+1}{2}*2^{n-1}=\left ( n+ 1\right )*2^{n-2}

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=200010;
const int mod=1000000007;
const int inf=0x3f3f3f3f;
const double eps=1e-8;
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0; i<n-1; i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
    }
    ll ans=n+1;
    for(int i=1; i<=n-2; i++)
    {
        ans*=2;
        ans%=mod;
    }
    printf("%lld\n",ans);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值