丑数(Humble Numbers )(动规)

丑数(Humble Numbers )(动规)

问题描述:
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence
(素数只有2、3、5或7的数称为素数。序列1、2、3、4、5、6、7、8、9、10、12、14、15、16、18、20、21、24、25、27、…显示前20个不起眼的数字。
编写一个程序来查找并打印这个序列中的第n个元素)

输入描述:
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
(输入由一个或多个测试用例组成。每个测试用例由一个整数n组成,其中1 <= n <= 5842。对于n,输入以一个值0(0)结束。)

输出描述:
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.
(对于每个测试用例,打印一行“第n个不起眼的数字就是数字”。根据n的值,必须使用序数n的正确后缀“st”、“nd”、“rd”或“th”,如示例输出中所示。)

样例输入:
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
样例输出:
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
#define min(a,b) (a<b?a:b)
#define min4(a,b,c,d) min(min(a,b),min(c,d))
using namespace std;
int a[5600];
int main()
{
    int p2,p3,p5,p7;
    p2=p3=p5=p7=1;
    int n=1;
    a[1]=1;
    while(a[n]<2000000001)//枚举2000000001个丑数放在数组a里
    {
        a[++n] = min4(2*a[p2],3*a[p3],5*a[p5],7*a[p7]);//从现在枚举的4个丑数里,先选择小的放在a里。
        if(a[n]==2*a[p2]) p2++;//如果a[n]==2*a[p2],2*a[p2]可能是把a[n]枚举出的数,这样p2++,也可能是重复的枚举,这样也是p2++,总之p2++。
        if(a[n]==3*a[p3]) p3++;//同理
        if(a[n]==5*a[p5]) p5++;//同理
        if(a[n]==7*a[p7]) p7++;//同理
    }
    while(~scanf("%d",&n),n)
    {
        if(n%10 == 1&&n%100!=11)//特判11
            printf("The %dst humble number is ",n);
        else if(n%10 == 2&&n%100!=12)//特判12
            printf("The %dnd humble number is ",n);
        else if(n%10 == 3&&n%100!=13)//特判13
            printf("The %drd humble number is ",n);
        else
            printf("The %dth humble number is ",n);
        printf("%d.\n",a[n]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值