Huatuo's Medicine (HDU - 5551 )

Huatuo's Medicine (HDU - 5551 )

Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these bottles together. 

However, there was a critical problem. When Huatuo arrived the patient's home, he took the chain out of his bag, and he could not recognize which bottle contains which type of medicine, but he remembers the order of the bottles on the chain. 

Huatuo has his own solution to resolve this problem. When he need to bring 2 types of medicines, E.g. A and B, he will put A into one bottle and put B into two bottles. Then he will chain the bottles in the order of ′−B−A−B−′. In this way, when he arrived the patient's home, he knew that the bottle in the middle is medicine A and the bottle on two sides are medicine B. 

Now you need to help Huatuo to work out what's the minimal number of bottles needed if he want to bring N types of medicine.

Input

The first line of the input gives the number of test cases, T(1≤T≤100). T lines follow. Each line consist of one integer N(1≤N≤100), the number of types of the medicine.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the minimal number of bottles Huatuo needed.

Sample Input

1
2

Sample Output

Case #1: 3

题目翻译:

华佗是一位著名的医生。他用同样的瓶子装药。有不同种类的药物。华佗把药放在瓶子里,把这些瓶子串在一起。

然而,有一个关键的问题。当华佗来到病人家中,他从包里拿出链子,他不知道哪个瓶子里装的是哪种药,但他记得链子上瓶子的顺序。

华佗有自己的办法来解决这个问题。当他需要带两种药物时,例如A和B,他会把A放入一个瓶子,然后把B放入两个瓶子。然后他将把瓶子按“- B - A - B -”的顺序锁起来。这样,当他到达病人的家,他知道中间的瓶子是药A,两边的瓶子是药B。

现在你需要帮助华佗算出,如果他要带N种药,最少需要多少瓶。

输入

输入的第一行给出测试用例的数量,T(1≤T≤100)。T线。每一行由一个整数N(1≤N≤100)组成,表示药品的种类数。

输出

对于每个测试用例,输出一行包含用例#x: y,其中x是测试用例号(从1开始),y是所需要的瓶数最少的瓶数。

样例输入

1

2

样例输出

例# 1:3

思路:2*n-1,很简单

AC代码:

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
    int t,n;
    int k=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("Case #%d: %d\n",k+=1,2*n-1);
    }
    return 0;
}

 

### Huatuo GPT 技术文档和应用案例 #### 技术文档概述 Huatuo GPT 是一款专注于医疗健康领域的大型预训练语言模型。该模型基于Transformer架构,经过大规模语料库的训练,在处理医学文本、疾病诊断辅助等方面表现出色[^1]。 为了更好地支持开发者和技术人员理解和使用Huatuo GPT,官方提供了详尽的技术文档。这些文档涵盖了从基础概念到高级特性的各个方面,包括但不限于: - **安装指南**:描述如何部署环境以及加载模型所需的依赖项。 - **API 参考手册**:详细介绍各个接口的功能及其参数配置方法。 - **最佳实践建议**:分享一些优化性能的经验技巧。 - **常见问解答FAQs**:列举并解决用户可能遇到的问。 #### 应用案例展示 ##### 病历自动摘要生成工具开发 通过调用Huatuo GPT 的 API 接口实现病历记录自动化总结功能。此项目能够帮助医生快速获取患者病情概览信息,提高工作效率的同时减少了人为错误的发生概率[^2]。 ```python import requests def generate_summary(text): url = "http://api.huatuogpt.com/v1/generate" payload = {"prompt": f"请为这段文字创建一个简洁明了的小结:\n{text}"} response = requests.post(url, json=payload).json() return response['choices'][0]['text'] example_text = """ 病人自述头痛持续三天未见好转, 伴有轻微发热现象;经初步检查发现血压偏高... """ print(generate_summary(example_text)) ``` ##### 基于对话系统的在线问诊平台构建 利用 HuaTuo-GPT 构建了一个可以模拟真实医患交流场景的人工智能助手。它不仅具备理解自然语言的能力,还能根据不同病症提供个性化的治疗方案推荐服务。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值