Power Strings (POJ-2406)

Power Strings (POJ-2406)

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路:KMP求循环节

AC代码:
 

#include <stdio.h>
#include <math.h>
#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
#include <map>
#include <vector>
#include <queue>
#include <stack>
#define PI 3.1415926
#define maxx 1000010
using namespace std;
char s[maxx];
int nex[maxx];
void Getnextval(char *s)
{
    int i=0;
    int j=-1;
    int slen=strlen(s);
    nex[0]=-1;
    while(i<slen)
    {
        if(j==-1 || s[i]==s[j])
        {
            i++;
            j++;
            nex[i]=j;
        }
        else
            j=nex[j];
    }
}
int main()
{
    while(~scanf("%s",s) && s[0]!='.')
    {
        int slen=strlen(s);
        Getnextval(s);
        int len=slen-nex[slen];
        if(slen%len==0)
         printf("%d\n",slen/len);
         else
            printf("1\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值