HDU-6630(打表找规律)(2019hdu多校第五场1007 permutation 2)

Problem Description

You are given three positive integers N,x,y.
Please calculate how many permutations of 1∼N satisfies the following conditions (We denote the i-th number of a permutation by pi):

1. p1=x

2. pN=y

3. for all 1≤i<N, |pi−pi+1|≤2

Input

The first line contains one integer T denoting the number of tests.

For each test, there is one line containing three integers N,x,y.

* 1≤T≤5000

* 2≤N≤105

* 1≤x<y≤N

Output

For each test, output one integer in a single line indicating the answer modulo 998244353.

Sample Input

3 4 1 4 4 2 4 100000 514 51144

Sample Output

2 1 253604680

Source

2019 Multi-University Training Contest 5

Recommend

liuyiding

题意:给你1-N个数字。给你x,y。p1=x,pN=y,且|pi-pi+1|<=2。求有几种排列方式。

思路:打表,找到规律,会发现是f[i]=(f[-1]+f[i-3])%mod;

AC代码:

#include <bits/stdc++.h>
const int maxx=100010;
const int inf=0x3f3f3f3f;
const int mod=998244353;
using namespace std;
long long ans[maxx];
int init()
{
    ans[0]=0,ans[1]=ans[2]=ans[3]=1;
    for(int i=4; i<maxx; i++)
    {
        ans[i]=((ans[i-1]+ans[i-3])%mod);
    }
}
int main()
{
    long long t,n,x,y;
    scanf("%lld",&t);
    init();
    while(t--)
    {
        scanf("%lld%lld%lld",&n,&x,&y);
        if(x==1 && y==n)
            printf("%lld\n",ans[y-x+1]);
        else if(x==1 || y==n)
            printf("%lld\n",ans[y-x]);
        else
            printf("%lld\n",ans[y-x-1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值