1152 —— Google Recruitment (20分)

1152  Google Recruitment (20分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constante. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist,output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

题目大意:给出一个 n 位数,找出第一个 k 位素数;注意输出要求(红色部分) ,里面有很重要的一点,如果这个数为素数,且有前导 0,要把前导 0 也输出;如果没有符合要求的素数,则要输出 404。

思路:枚举每一位 k 位数,判断它是否是素数,如果是素数,就停止,之后输出。

我的AC代码:

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int su(int n){
	if(n < 2)  return 0;
	for(int i = 2; i <= sqrt(n); i++){
		if(n%i == 0){
			return 0;
		}
	}
	return 1;
}
int main(){
	int n, m, flag=0;
	string s;
	cin >> n >> m >> s;
	for(int i = 0; i+m <= n; i++){
		string t = s.substr(i, m);
		int k = stoi(t);
		if(su(k)){
			flag = 1;
			cout << t;
			break;
		}
	}
	if(!flag){
		cout << 404;
	}
	return 0;
} 

分析:在素数判断方面,时间复杂度较大,此处还可以进行优化;

老师的代码:

#include <cstdio> 
#include <cstdlib> 
const int N = 1e5 + 7; 
int pr[N]; 
bool isCp[N]; 
void EulerSieve() {     
    isCp[0] = isCp[1] = true;     
	for (int i = 2; i < N; ++i) {         
	    if (not isCp[i]) pr[++pr[0]] = i;         
	    for (int j = 1; j<=pr[0] && i*pr[j]<N; ++j) {             
	        isCp[i*pr[j]] = true;             
		    if (i%pr[j] == 0) break;         
    	}     
	} 
} 
bool isPrime(long long x) {     
    if (x <= 1e5) return not isCp[x];     
	for (int i = 1; i<=pr[0] && 1LL*pr[i]*pr[i]<=x; ++i)         
	    if (x%pr[i] == 0) return false;     
	return true; 
} 
int main() {     
        int n, k;     
	char s[1007];     
	EulerSieve();     
	scanf("%d%d%s", &n, &k, s);     
	for (int i = 0; s[i+k-1]; ++i) {         
	    char c = s[i+k]; s[i+k] = 0;         
		long long x = atoll(s+i);         
		if (isPrime(x)) { 
		    puts(s+i); 
		    return 0; 
		}         
	    s[i+k] = c;     
	}     
	puts("404");     
	return 0; 
} 
 
  

到这里,就应该复习一下素数的判断啦 ~~~ 

查看此博客:素数的判断

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值