1154 Vertex Coloring (25分)

1154  Vertex Coloring (25分)

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (properk-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

开始的时候没看懂题目,翻译过来才看懂,额~~~,英语不好真要命,好好学英语很重要 ---------

题目大意:第一行给出 n 个顶点和 m 条边,下面的 m 行给出一条边连接的两个顶点,再一行给出一个整数 k,下面给出 k 组测试数据,每组测试数据有 n 个,表示第 i 个顶点的颜色。在一组测试数据中,如果两个顶点相连,并且顶点的颜色不同,统计一下顶点中共有几种颜色,输出 颜色数量-coloring;如果有一组相连的顶点的颜色相同,则输出 No。

思路:思路其实很简单,存储边和顶点的颜色(用 set 存储顶点的颜色,以便统计顶点颜色的个数),对每组测试数据,去枚举每条边所连接的顶点是否颜色相同,若全不相同,则输出颜色个数;否则,输出 No。

第一次写的时候用二维数组去存储边,超时了,呜呜呜~~~~~  但是思路是完全没有问题的,还是要好好思考怎么解决超时的问题!

#include<iostream>
#include<set>
using namespace std;
const int maxn = 1e4+7;
bool ver[maxn][maxn];
int main(){
	int n, m, x, y, k;
	
	cin >> n >> m;
	for(int i = 0; i < m; i++){
		cin >> x >> y;
		ver[x][y] = true;
		ver[y][x] = true;
	}
	cin >> k;
	while(k--){
		int a[maxn];
		int flag=1;
		set<int> s;
		for(int i = 0; i < n; i++){
			cin >> a[i];
			s.insert(a[i]);
		}
		for(int i = 0; i < n; i++){
			if(!flag){
				break;
			}
			for(int j = i+1; j < n; j++){
				if(ver[i][j]==true && a[i]==a[j]){
					flag = 0;
					break;
				}
			}
		}
		if(flag){
			cout << s.size() << "-coloring" << endl;
		}
		else{
			cout << "No" << endl;
		}
		s.clear();
	}
	return 0;
} 

第二次用了 vector 存储边,一次过,😄😄

AC代码:

#include<iostream>
#include<vector>
#include<set>
using namespace std;
const int maxn = 1e4+7;
typedef struct{
	int x, y;
}node;
int main(){
	int n, m, k;
	cin >> n >> m;
	vector<node> v(m);
	for(int i = 0; i < m; i++){
		cin >> v[i].x >> v[i].y;
	}
	cin >> k;
	while(k--){
		int a[maxn];
		int flag=1;
		set<int> s;
		for(int i = 0; i < n; i++){
			cin >> a[i];
			s.insert(a[i]);
		}
		for(int i = 0; i < m; i++){
			if(a[v[i].x] == a[v[i].y]){
				flag = 0;
				break;
			} 
		}
		if(flag){
			cout << s.size() << "-coloring" << endl;
		}
		else{
			cout << "No" << endl;
		}
		s.clear();
	}
	return 0;
} 

老师的代码:

#include <cstdio> 
#include <unordered_map> 
const int N = 1e4 + 7; 
typedef std::pair<int, int> Edge; 
Edge eg[N]; 
int cl[N], cnt[N]; 
std::unordered_map<int, bool> mp; 
int main() {     
    int n, m, k;     
	scanf("%d%d", &n, &m);     
	for (int i = 1, u, v; i <= m; ++i) {         
	    scanf("%d%d", &u, &v);         
		eg[i] = Edge{u, v};     
	}     
	scanf("%d", &k);     
	while (k--) {         
	    mp.clear();         
		int i;         
		for (i = 0; i < n; ++i)              
		    scanf("%d", cl + i), mp[cl[i]] = true;         
		for (i = 1; i <= m; ++i) {             
		    int u = eg[i].first, v = eg[i].second;             
			if (cl[u] == cl[v]) { 
			    puts("No"); 
				break; 
			}         
		}         
		if (i > m) 
		    printf("%lu-coloring\n", mp.size());     
	}     
	return 0; 
}   

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值