1150  Travelling Salesman Problem (25分)

1150  Travelling Salesman Problem (25分)

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

题目大意:给出一个无向图的顶点数 n 和边数 m,下面 m 行,每行有三个数,分别是一条边的两个顶点以及边的权值,之后输入一个 T,下面有 T 行,每行输入一组数据,每组数据第一个数为输入顶点的总数 r,随后输入 r 个顶点,用数组 a[] 存储,判断这 r 个顶点是否构成环路

思路:用邻接矩阵(二维数组)存储边,用 set 来存储输入的不同的顶点的个数,用来判断构成的回路中是否包含了全部顶点。用 flag 来标记是否每两个顶点之间都有边存在,如果存在,记为 1;如果不存在,记为 0;用 sum 记录路径的总权值。

1. 如果 flag == 0,直接输出 "Path T: NA (Not a TS cycle)"

2. 如果 flag == 1,分情况讨论:

(1)如果不同的顶点个数等于 n 并且 r == n+1,即 s.size()==n && r==n+1;输出 "Path T: sum (TS simple cycle)";

  (2)  如果 a[0] != a[r-1] 或者 s.size()!=n,输出 "Path T: sum (Not a TS cycle)";

(3)如果 a[0] == a[r-1] && r != n+1,输出 "Path T: sum (TS cycle)"。

3. 最后输出这些环路中经过的路径最短的路径编号和路径长度。

AC代码:

#include<iostream>
#include<set>
using namespace std;
int n, m, minn=1e5+7, t;
int e[500][500];
void print(int T){
	int r, flag=1, sum=0;
	cin >> r;
	int a[500];
	set<int> s;
	for(int i = 0; i < r; i++){
		cin >> a[i];
		s.insert(a[i]);
	}
	for(int i = 0; i < r-1; i++){
		if(e[a[i]][a[i+1]] == 0){
			flag = 0;
		}
		else{
			sum += e[a[i]][a[i+1]];
		}
	}
	if(flag == 0){
		printf("Path %d: NA (Not a TS cycle)\n", T);
	}
	else if(a[0]!=a[r-1] || s.size()!=n){
		printf("Path %d: %d (Not a TS cycle)\n", T, sum);
	}
	else if(s.size() == n && r == n+1){
		printf("Path %d: %d (TS simple cycle)\n", T, sum);
		if(minn > sum){
			minn = sum;
			t = T;
		}
	}
	else if(r != n+1){
		printf("Path %d: %d (TS cycle)\n", T, sum);
		if(minn > sum){
			minn = sum;
			t = T;
		}
	}
}
int main(){
	int T;
	cin >> n >> m;
	for(int i = 0; i < m; i++){
		int x, y, value;
		cin >> x >> y >> value;
		e[x][y] = e[y][x] = value;
	}
	cin >> T;
	for(int i = 1; i <= T; i++){
		print(i);
	}
	printf("Shortest Dist(%d) = %d", t, minn);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值