1013  Battle Over Cities (25分)

Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题意:给出n个城市之间有相互连接的m条道路,当删除一个城市和其连接的道路的时候,问其他几个剩余的城市至少要添加多少个路线才能让它们重新变为连通图(给出 n 个点,m条边,k 个测试数据;m 行,每行两个数 u 和 v,表示 u 和 v之间有边相连;k 行,每行一个数 a,问去掉点 a 以及和点 a 相连的边,剩下的点需要连几条边才能构成一个连通图;)

思路:添加的最少的路线,就是他们的连通分量数 - 1

当 a 个互相分立的连通分量需要变为连通图的时候,只需要添加 a-1 个路线。所以这道题就是求去除了某个结点之后其他的图所拥有的连通分量数;

使用邻接矩阵存储,对于每一个被占领的城市,去除这个城市结点,就是把它标记为已经访问过,这样在深度优先遍历的时候,对于所有未访问过的结点进行遍历,就能求到所有的连通分量的个数~~~  由于有很多个要判断的数据,每一次输入被占领的城市之前要把 v 数组置为false~~

注意:不能用 cin 和 cout,有一个测试点会超时;

c++代码 

#include<iostream>
#include<cstdio>
const int N = 5010;
int edge[N][N], v[N];
int n;
void dfs(int x){
	v[x] = true;
	for(int i = 1; i <= n; i++){
		if(v[i]==false && edge[x][i]==1){
			dfs(i);
		}
	}
}
int main(){
	int m, k;
	scanf("%d%d%d", &n, &m, &k);
	for(int i = 0; i < m; i++){
		int u, v;
		scanf("%d%d", &u, &v);
		edge[u][v] = edge[v][u] = 1;
	}
	for(int i = 0; i < k; i++){
		int a;
		scanf("%d", &a);
		std::fill(v, v+N, false);
		int cnt = 0;
		v[a] = true;
		for(int j = 1; j <= n; j++){
			if(v[j] == false){
				dfs(j);
				cnt++;
			}
		}
		printf("%d\n", cnt-1);
	}
	return 0;
}

Python代码

class city:
def __init__(self, name):
self.name = name
self.conn = []
def main():
line = input().split(" ")
n = int(line[0])
m = int(line[1])
k = int(line[2])
cities = {}
for x in range(n):
c = city(x+1)
cities[x+1] = c
for x in range(m):
line = input().split(" ")
come = int(line[0])
to = int(line[1])
cities[come].conn.append(to)
cities[to].conn.append(come)
line = input().split(" ")
conc = [int(x) for x in line]
for x in conc:
a = [0 for x in range(n)]
a[x-1] = 1
repair = -1
while(sum(a) <n):
start = a.index(0)
step = [start+1]
new = [start+1]
temp = []
while(len(new) > 0):
for i in new:
for j in cities[i].conn:
if j not in step and j !=x:
temp.append(j)
step += temp
new = temp
temp = []
repair += 1
for i in step:
a[i-1] = 1
print(repair)
if __name__ == "__main__":
main()

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值