1013 Battle Over Cities

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0


题型分类:图的遍历

题目大意:给出需要检查的城市,假设这个城市无法访问时,需要几条边才能让整个图成为连通图。

解题思路:用DFS对图进行遍历,用cnt变量记录需要遍历几次才能遍历完全图即可。


#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 1010;

int G[maxn][maxn];
bool visited[maxn];
int N, M, K;

void DFS(int u);

int main(int argc, char** argv) {
	scanf("%d %d %d", &N, &M, &K);
	fill(G[0], G[0] + maxn * maxn, INF);
	for(int i = 0; i < M; i++){
		int c1, c2;
		scanf("%d %d", &c1, &c2);
		G[c1][c2] = G[c2][c1] = 1;
	}
	while(K--){
		int query, cnt = -1;
		scanf("%d", &query);
		memset(visited, false, sizeof(visited));
		visited[query] = true; //排除的城市设置为访问过即可 
		for(int i = 1; i <= N; i++){ //注意城市的编号从1开始 
			if(visited[i] == false){
				DFS(i);
				cnt++;
			}
		}
		printf("%d\n", cnt);
	}
	return 0;
}

void DFS(int u){
	visited[u] = true;
	for(int v = 1; v <= N; v++){
		if(visited[v] == false && G[u][v] == 1){
			DFS(v);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值