Degree Sequence of Graph G(模拟+Havel定理)

题目描述

Wang Haiyang is a strong and optimistic Chinese youngster. Although born and brought up in the northern inland city Harbin, he has deep love and yearns for the boundless oceans. After graduation, he came to a coastal city and got a job in a marine transportation company. There, he held a position as a navigator in a freighter and began his new life.

The cargo vessel, Wang Haiyang worked on, sails among 6 ports between which exist 9 routes. At the first sight of his navigation chart, the 6 ports and 9 routes on it reminded him of Graph Theory that he studied in class at university. In the way that Leonhard Euler solved The Seven Bridges of Königsberg, Wang Haiyang regarded the navigation chart as a graph of Graph Theory. He considered the 6 ports as 6 nodes and 9 routes as 9 edges of the graph. The graph is illustrated as below.

According to Graph Theory, the number of edges related to a node is defined as Degree number of this node.

Wang Haiyang looked at the graph and thought, “If arranged, the Degree numbers of all nodes of graph G can form such a sequence: 4, 4, 3,3,2,2, which is called the degree sequence of the graph. Of course, the degree sequence of any simple graph (according to Graph Theory, a graph without any parallel edge or ring is a simple graph) is a non-negative integer sequence”

Wang Haiyang is a thoughtful person and tends to think deeply over any scientific problem that grabs his interest. So as usual, he also gave this problem further thought, “as we know, any a simple graph always corresponds with a non-negative integer sequence. But whether a non-negative integer sequence always corresponds with the degree sequence of a simple graph? That is, if given a non-negative integer sequence, are we sure that we can draw a simple graph according to it.”

Let’s put forward such a definition: provided that a non-negative integer sequence is the degree sequence of a graph without any parallel edge or  ring, that is, a simple graph, the sequence is draw-possible,  otherwise, non-draw-possible. Now the problem faced with Wang Haiyang is how to test whether a non-negative integer sequence is draw-possible or not. Since Wang Haiyang hasn’t studied Algorithm Design course, it is difficult for him to solve such a problem. Can you help him?

 

输入

The first line of input contains an integer T, indicates the number of test cases. In each case, there are n+1 numbers; first is an integer n (n<1000), which indicates there are n integers in the sequence; then follow n integers, which indicate the numbers of the degree sequence.

输出

For each case, the answer should be “yes” or “no”, indicating this case is “draw-possible” or “non-draw-possible”.

 

样例输入

2
6 4 4 3 3 2 2
4 2 1 1 1

样例输出

yes
no

 

【题意】

通过给出的每个节点的度数判断能否构成一个简单图。

 

 

【补充】

Havel定理:

给定一个非负整数序列{dn},若存在一个无向图使得图中各点的度与此序列一一对应,则称此序列可图化。进一步,若图为简单图,则称此序列可简单图化。

可图化的判定:d1+d2+……dn=0(mod 2)。关于具体图的构造,我们可以简单地把奇数度的点配对,剩下的全部搞成自环。

可简单图化的判定(Havel定理):把序列排成不增序,即d1>=d2>=……>=dn,则d可简单图化当且仅当d’={d2-1,d3-1,……d(d1+1)-1, d(d1+2),d(d1+3),……dn}可简单图化。简单的说,把d排序后,找出度最大的点(设度为d1),把它与度次大的d1个点之间连边,然后这个点就可以不管了,一直继续这个过程,直到建出完整的图,或出现负度等明显不合理的情况。

 

【代码】

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n,j,i,t;
    int a[1010];
    cin>>t;
    while(t--)
    {
        int f=0,sum=0;
        cin>>n;
        for(i=0;i<n;i++)
        {
            cin>>a[i];
            if(a[i]>=n)
                f=1;
            sum+=a[i];
        }
        if(sum%2||f)//度数和为奇数或者某个节点的度数大于等于n时一定不能构成简单图
        {
            cout<<"no\n";
            continue;
        }
        for(int i=0;i<n;i++)
        {
            int cnt=0;
            sort(a,a+n,cmp);
            for(j=1;j<n;j++)
            {
                if(cnt==a[0])//已模拟完与度数最大的点的连线
                    break;
                a[j]--;//若与度数最大的点模拟连线,就消掉该条线
                cnt++;
                if(a[j]<0)//如果出现某个点度数为负数的情况,就说明该序列无法构成简单图,停止模拟
                {
                    f=1;
                    break;
                }
            }
            if(f==1||cnt==0)
                break;
            a[0]-=cnt;
        }
        for(int i=0;i<n;i++)
        {
            if(a[i]!=0)//若能构成简单图,则模拟完后每个节点的度数都为0
            {
                f=1;
                break;
            }
        }
        if(f==1)
            cout<<"no\n";
        else
            cout<<"yes\n";
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值