sdnu1592 easy problem(线性基)

Description

Albert_s has a multiset S, this question requires you to find a subset T of S that maximizes the expression of xor xor xor ​.

Input

The first line contains the integer indicating to the size of S.

The second line contains integer 、、、​ indicating the element in S.

Output

Output the maximum value of xor xor xor ​.

Sample Input

4
5 2 8 2

Sample Output

15

得 我孤陋寡闻 这题凉了

线性基:

https://www.cnblogs.com/yangsongyi/p/10692292.html

模板:

void ins(ll x)
{
    for(int i = 52 ; i >= 0 ; i-- )
    {
        if(!( x >> (1ll * i))) continue ;
        if(!p[i])
        {
            p[i] = x ;
            break ;
        }
        x = x ^ p[i] ;
    }
}

求完线性基后,贪心求异或最大值,高位数字的贡献要大于它后面所有地位数字的贡献,当前位数上的数异或答案后使得答案更大时,就更新

太菜了太菜了

#include <bits/stdc++.h>
#include <bitset>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int inf = 0x3f3f3f3f;
const int N = 60;
const int mod = 998244353;

ll s, p[N];

void ins(ll x)
{
    for(int i = 52; i >= 0; --i)
    {
        if(!(x >> (1ll * i)))
            continue;
        if(!p[i])
        {
            p[i] = x;
            break;
        }
        x ^= p[i];
    }
}

int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        memset(p, 0, sizeof(p));
        for(int i = 1; i <= n; ++i)
        {
            scanf("%lld", &s);
            ins(s);
        }
        ll ans = 0;
        for(int i = 52; i >= 0; --i)
        {
            if((ans ^ p[i]) > ans)
                ans ^= p[i];
        }
        cout<<ans<<'\n';
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值